ACQ improved duplicate order detection

Bug #1350371 reported by Bill Erickson on 2014-07-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

In Summary:

1. Detect duplicate PO names (for a given ordering agency) and warn the user during PO creation.
2. Display the number of catalog copies already owned at or below the ordering agency next to each lineitem in the PO interface.

Proposed specs:

http://yeti.esilibrary.com/dev/pub/techspecs/acq-dupe-orders.html

Additions / alterations to the proposed spec.

1. What's not clear in the specs is that an option to apply/modify the PO name will now be present in the PO creation dialog. As before, it will default to the PO ID.

2. The statuses of copies to ignore in the existing copy count should be expanded to include: Lost, Missing, Discard/Weed, and Lost and Paid. Note that "copy_active" and other existing config.copy_status flags are a little too broad for this, though a new "count-this-copy-as-existing" flag is an option if needed.

Bill Erickson (berick) on 2014-08-04
Changed in evergreen:
assignee: Bill Erickson (erickson-esilibrary) → nobody
Tim Spindler (tspindler-cwmars) wrote :

We have tested this development and it has worked as designed.

Ben Shum (bshum) wrote :

Assigning back to 2.next for review during next development cycle.

Changed in evergreen:
milestone: 2.7.0-beta1 → 2.next
Kathy Lussier (klussier) on 2015-01-08
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

Works for me! The duplicate PO check worked whenever I created an order under the same agency. If I created an order for another branch, no warnings were issued. It also successfuly displayed the number of live copies I already owned for a particular lineitem.

Signoff branch is available at:
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1350371-acq-dupe-orders-detect

tags: added: signedoff
Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
milestone: 2.next → 2.8-beta
Mike Rylander (mrylander) wrote :

Merged to master for 2.8. Thanks, Bill and Kathy.

Changed in evergreen:
assignee: nobody → Mike Rylander (mrylander)
status: New → Fix Committed
assignee: Mike Rylander (mrylander) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers