Content Cafe module should use an XML lookup method

Bug #1347805 reported by Thomas Berezansky on 2014-07-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

From the documentation I received for the Content Cafe API when we signed up for the service the methods Evergreen is currently using for lookups generally fall into the "test to make sure this is working" category, not the "do your normal lookups this way" method. The exception being the image lookup method, which falls into the "directly load the image off of our server" category instead.

The branch below changes this, teaching the Content Cafe module how to do XMLPost lookups. This additionally gives us the benefit of multiple ISBN and UPC lookups in a single call as well as generally including UPCs.

We lose the "no image vs blank image" option as that is no longer needed. Instead we can report a 404 when we have no image, whether or not that was because of not having identifiers at all or Content Cafe not having one.

We gain an option to prefer ISBN or UPC, or to ignore one or the other.

In addition there is a small addition to AddedContent.pm for the "send a post request" method instead of embedding that in the Content Cafe module itself.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/tsbere/contentcafe_xmlpost

Changed in evergreen:
milestone: none → 2.7.0-beta1
status: New → Confirmed
importance: Undecided → Wishlist
Ben Shum (bshum) wrote :

When i tried this using some sample contentcafe test codes, I got memcache errors in my logs like "could not store xxxx in memcache server" for searches, facets, book jackets, etc. Visually, the facets did not display, though the book jackets worked and there appeared to be attempts at showing the added contents inside the tabs.

Not sure what happened, marking this bug as incomplete pending further testing and feedback.

Changed in evergreen:
status: Confirmed → Fix Committed
status: Fix Committed → Incomplete
milestone: 2.7.0-beta1 → 2.next
Jason Stephenson (jstephenson) wrote :

You should try this again now that 1347793 is in. I always load them both in development and training.

Ben Shum (bshum) wrote :

Actually I had both commits in the same branch. ContentCafe gave me errors so I tried stock OpenLibrary and also used our Syndetics account to test that. Both of those worked fine, but ContentCafe was repeatedly broken each time I tested it. Reverting this commit and then testing ContentCafe worked. So it definitely seemed to just be an issue with the changes in this branch. It could be Ubuntu 14.04 issue of some sort, though. I'll try it again on a 12.04 server later.

Jason Stephenson (jstephenson) wrote :

I have been using it on Ubuntu 14.04 with an actual Content Cafe account. I wonder if the XML Post method works with the demo account information. The interface we were using prior to this was meant for demo purposes.

I'm not trying to force this in, I respect your judgement. I'd feel better knowing there were errors if someone else with a Content Cafe account tested it and saw them.

We've not seen these errors and we've been using it on development and training servers for over two weeks. We plan to put it in production this Sunday evening.

Ben Shum (bshum) wrote :

I tested it again on a new test server using a different ContentCafe code and it worked this time. Maybe something I typo'd in the other server.

In any case, back on track, pushed to master. Thanks for persisting Jason, hopefully we'll get some live test results on this.

Changed in evergreen:
status: Incomplete → Fix Committed
milestone: 2.next → 2.7.0-beta1
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers