Uploading and activating orders with an inactive fund should not be possible

Bug #1347090 reported by Kathy Lussier on 2014-07-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Evergreen version: tested on recent version of master, but probably applies to earlier versions

If you upload order records with inactive funds entered in the holdings tag (or, perhaps, select the wrong fiscal year in the order upload form) the records will successfully upload and activate.

At some step in the process, the system should stop the user from placing an order that encumbers/expends an inactive fund. My preference would be to have a stop in the Activatable? field of the PO, similar to the one used for over-encumbered funds, that alerts the users that there are inactive funds in the order and prevents them from activating the order.

Tags: acq Edit Tag help
Erica Rohlfs (erohlfs) wrote :

I'm having a difficult time reproducing this bug in version 2.8.1. When I attempt to use a fund within my holding tag that has been deactivated, I receive an "attempt to query DB failed" error. Although, this error could mean a few other things, too. I can leave the fiscal year at a previously closed out year and create a PO; however, I have not actually applied a fund to the records/items at this point. I would then be directed into the PO, where I need to select an active fund. I'm going to mark this as triaged, because I don't want to invalidate it, confirm, or say it's fixed, etc. simply because I don't know if the error I am receiving is, in fact, due to a closed out fund being attached to the incoming records.

Changed in evergreen:
status: New → Triaged
Christine Morgan (cmorgan-z) wrote :

I can confirm that this issue still exists in 2.8.2. We had a few instances where the Fiscal Year drop down was not reset set to the new fiscal year after the fiscal close process had been completed. Users were able to upload, and then activate, POs with 2015 set in the upload screen, rather than 2016. Line item amounts were encumbered in the 2015 funds even though they were inactive.

Christine Morgan (cmorgan-z) wrote :

Confirming that this is still an issue in 2.12.2.

Kathy Lussier (klussier) on 2017-07-19
Changed in evergreen:
status: Triaged → Confirmed
Kathy Lussier (klussier) wrote :

Re-thinking my initial report, I actually think the preferred behavior is for the system to deal with this problem at upload time instead of informing the user of the problem at a later time.

Ideally, after the user clicks upload, if the system saw that any lineitems had an inactive fund, the upload would fail with a message informing the user what the problem is. I know the system will fail uploads where there are other issues with holdings subfields (see bug 924952), but the message the user receives is not very informative.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers