TPAC copy edit links

Bug #1346421 reported by Bill Erickson on 2014-07-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Feature request for adding links to the TPAC which allow staff to jump directly from the copy grid to the copy edit interface.

Proposed specs: http://yeti.esilibrary.com/dev/pub/techspecs/tpac-edit-items.html

In short, add a column to the copy grid containing "view" and "edit" links. The only element of this which may be (very mildly) controversial is my comment "The existing barcode link will be downgraded to a simple text field to avoid duplication of actions." I don't have a strong preference about killing the link, but having two links practically right beside each other that have the same behavior seems less than ideal. (Also, if the barcode is not a link, it's easier to copy to the clipboard via dbl-click).

Bill Erickson (berick) wrote :

Slight clarification, the view / edit links can just live next to the barcode. I don't see a strong need to create a new labeled column.

Bill Erickson (berick) wrote :
tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.7.0-beta1
status: In Progress → Confirmed
assignee: Bill Erickson (erickson-esilibrary) → nobody
Kathy Lussier (klussier) wrote :

Hi Bill,

Can you add a release notes entry for this one?

Thanks!
Kathy

tags: added: needsreleasenote
Bill Erickson (berick) wrote :

Release notes pushed.

tags: removed: needsreleasenote
Ben Shum (bshum) wrote :

Works for me, pushed to master, thanks Bill!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers