Copy Location Groups search not retaining original search params after searching

Bug #1340852 reported by Steve Callender on 2014-07-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.8
Undecided
Unassigned

Bug Description

I've tested this in 2.5 and 2.6.

When having a Copy Location Group that is Opac visible, when doing a search and selecting it in the Library: drop down box, the search appears to work correctly. However, the Library: box reverts back to the main org unit who owns the Copy Location after the search rather than keeping the original selection. This causes users to have to re-select the copy location once again if they want to do a second or third search.

It looks like on the 2.4 release, the copy location value used to stick in the box so there wasn't a need to re-select it.

Steve

Kathy Lussier (klussier) wrote :

I think I've traced the problem to

http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=dcf9cb39d3243ea3a59035c150d521cf5816b9c8

If I revert the changes made to misc_util.tt2 in that commit, I am able to retain the copy location group value in the drop down box. Of course, reverting that change also breaks the ability to search by shortname.

Kathy Lussier (klussier) on 2014-07-16
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Jake Litrell (jake-3) wrote :

Fixed with a minor tweak - the order in which we determined what to select in the Library dropdown put the resolved locg first (which allows for shortnames, e.g. BR1). That only gives us half the location group though, which is why it was bumping up a level. Now, if we have a location group selected, it will use that first (since they don't have shortnames); the remaining select order will be the same.

To test:
  - select a location group from the "Library" dropdown and hit the Search button (empty search field is fine). The resulting page should maintain that Library selection.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=ce73efae53a3ff08adb86a9ff790bae0c3f2ab52

user/jlitrell/lp1340852_copy_location_group_retain_search_params

tags: added: pullrequest
Kathy Lussier (klussier) wrote :

It works for me. The dropdown made the appropriate selection when I chose an org unit or a copy location group and when I used a shortname in the URL.

A signoff branch is available at:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1340852_copy_location_group_retain_search_params

For those who are testing this one a system with Concerto data, the Juvenile Collection and Local Interest Collection copy location groups can be used to see the bug and to see that it is fixed.

Thanks Jake!

tags: added: signedoff
Ben Shum (bshum) wrote :

Works for me too. Pushed to master and backported to rel_2_9 and rel_2_8.

Changed in evergreen:
milestone: none → 2.9.1
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers