non-Stripe credit card payments in TPac fail

Bug #1321411 reported by Galen Charlton on 2014-05-20
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
2.6
High
Unassigned

Bug Description

When using a non-Stripe payment processor (e.g., PayPal, authorize.net, etc.), attempting to pay a fine via TPac fails with an internal server error upon submitting the payment information. The corresponding logged error message looks like this:

2014-05-20 09:30:42 asp-nc-app1 logger: [Tue May 20 09:30:42 2014] [error] [client 192.168.25.230] egweb: Context Loader error: Exception: OpenSRF::EX::ERROR 2014-05-20T09:30:42 OpenILS::WWW::EGWeb /usr/local/share/perl/5.10.1/OpenILS/WWW/EGWeb.pm:115 System ERROR: Call to open-ils.circ for method open-ils.circ.money.payment \n failed with exception: Exception: OpenSRF::EX::ERROR 2014-05-20T09:30:42 OpenILS::Application::AppUtils /usr/local/share/perl/5.10.1/OpenILS/Application/AppUtils.pm:201 System ERROR: Exception: OpenSRF::DomainObject::oilsMethodException 2014-05-20T09:30:42 OpenSRF::AppRequest /usr/local/share/perl/5.10.1/OpenSRF/AppSession.pm:1086 <500> *** Call to [open-ils.circ.money.payment] failed for session [1400592642.179361330.98024713396], thread trace [1]:\nunspecified processor at /usr/local/share/perl/5.10.1/OpenILS/Application/Circ/CreditCard.pm line 231.\n\n\n\n : \n

The cause appears to be an oversight in the patch for bug 1227871, which ends up failing to send the processor code to OpenILS::Application::Circ::CreditCard::process_payment.

Evergreen master
Evergreen 2.6

Galen Charlton (gmc) wrote :

A patch is available in the user/gmcharlt/lp1321411_fix_non_stripe_cc_payments branch of the working/Evergreen repository. Not putting a pullrequest on yet pending testing.

Changed in evergreen:
importance: Undecided → High
milestone: none → 2.6.1
Galen Charlton (gmc) wrote :

I've received confirmation that the patch fixes the problem for one of our customers, so I'm slapping on pullrequest on the branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1321411_fix_non_stripe_cc_payments

tags: added: pullrequest
tags: added: opac
Dan Wells (dbw2) wrote :

Looks good to me. Pushed to master and rel_2_6. Thanks, Galen!

Changed in evergreen:
milestone: 2.6.1 → 2.next
status: New → Fix Committed
Ben Shum (bshum) on 2014-07-23
Changed in evergreen:
milestone: 2.next → 2.7.0-alpha1
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers