double-escaped entity in "Summaries & More" label

Bug #1319964 reported by Galen Charlton on 2014-05-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.6
Undecided
Unassigned
2.7
Undecided
Unassigned

Bug Description

The "Summaries & More" extra content tab on the bib details page is being displayed as "Summaries & More"; i.e., the "&" in the template is ending up becoming "&" in the rendered page.

This has been observed in two different 2.6.0 installations but, oddly, not in a 2.5.3 one.

Testing note: one make to make that tab display is viewing a record that has a 520$a.

Evergreen 2.6.0

Athira S (athirasnamby) wrote :

Hi I am beginner and I would like to work on this bug.Could someone please assign this bug for me?

Changed in evergreen:
assignee: nobody → Athira S (athirasnamby)
Kathy Lussier (klussier) wrote :

Hi Athira,

It looks like you have already assigned yourself to the bug. If you have any questions as you work on it, don't hesitate to ask!

Hello Athira, I accidentally reported a dup of this bug (Bug #1379797), I listed which file you need to edit to fix this. If you need any help let me know. Let me know if your not going to work on it and I'll take care of it.

This bug seems to affect 2.2 and greater, so the fix can pushed to master, 2.7, 2.6 and 2.5.

Josh

Athira S (athirasnamby) wrote :

I got the source package,How will Ifind the file where the bug is existing.?

I got the source package,How will Ifind the file where the bug is existing.?

On Sat, Oct 11, 2014 at 1:35 AM, Josh Stompro <email address hidden> wrote:

> Hello Athira, I accidentally reported a dup of this bug (Bug #1379797),
> I listed which file you need to edit to fix this. If you need any help
> let me know. Let me know if your not going to work on it and I'll take
> care of it.
>
> This bug seems to affect 2.2 and greater, so the fix can pushed to
> master, 2.7, 2.6 and 2.5.
>
> Josh
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1319964
>
> Title:
> double-escaped entity in "Summaries & More" label
>
> Status in Evergreen - Open ILS:
> New
>
> Bug description:
> The "Summaries & More" extra content tab on the bib details page is
> being displayed as "Summaries &amp; More"; i.e., the "&amp;" in the
> template is ending up becoming "&amp;amp;" in the rendered page.
>
> This has been observed in two different 2.6.0 installations but,
> oddly, not in a 2.5.3 one.
>
> Testing note: one make to make that tab display is viewing a record
> that has a 520$a.
>
> Evergreen 2.6.0
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/evergreen/+bug/1319964/+subscriptions
>

--
Athira S
S3 CSE, Amrita University
http://athirasnamby.blogspot.in/

Nothing is Impossible

Hello Athira, the file you are looking for is Evergreen / Open-ILS / src / templates / opac / parts / record / extras.tt2.

You can use the search features of whatever operating system you are using to find the file. Most people don't do development using the source package though.

For this fix I would suggest that you use the editing features of github, since it is a 4 character removal fix.

A quick guide on how to do this is part of the Documentation Interest Group - How to contribute pages.
http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:how-to-contribute-documentation

Intermediate

    Login to GitHub (or create a free account)
    Find the relevant file in the GitHub repository - https://github.com/evergreen-library-system/Evergreen/blob/master/Open-ILS/src/templates/opac/parts/record/extras.tt2
        Look around until you find the content (note: the directories are mostly logically similar to the online docs table of contents sections, but may require some searching around)
    Click the “Edit” button to edit the file in your browser
    Make your changes, using correct AsciiDoc format.
    Test that your AsciiDoc syntax is correct. This is not required for simple typo corrections.
        Test by creating a Gist and naming it filename.adoc. This will display the HTML version of your file. Then you can proofread your document and look for anything strange.
    Type a message describing your change
    Click the “Propose file change” button
    One of the developers will review your change and send you feedback

Oh, I forgot, Remember to sign off on your change as mentioned on http://evergreen-ils.org/dokuwiki/doku.php?id=contributing - the DCO is at the bottom of that page. Generally you just need to add "Signed-off-by: [submitter's name and email address here]" to the end of your commit.

Josh

Michael Peters (mrpeters) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Athira S (athirasnamby) → Michael Peters (mrpeters)
Galen Charlton (gmc) on 2014-12-23
Changed in evergreen:
status: New → Confirmed
assignee: Michael Peters (mrpeters) → nobody
milestone: none → 2.next
Galen Charlton (gmc) wrote :

I've committed a modified version of Mike's patch to master, rel_2_7, and rel_2_6. Thanks, Mike!

Changed in evergreen:
status: Confirmed → Fix Committed
Ben Shum (bshum) wrote :

Removing 2.next top level milestone, since this was a bug fix that was repaired in an actual series maintenance release.

Changed in evergreen:
milestone: 2.next → none
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers