Need Ubuntu 14.04 Trusty Makefile target for Evergreen

Bug #1315531 reported by Ben Shum on 2014-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Evergreen master (maybe 2.6)

For consideration, now that Ubuntu 14.04 has been released, we need to get Evergreen working with the latest LTS server edition from Ubuntu. We definitely should support it in master for 2.next, but we may wish to see this backported to the recently released 2.6 series of Evergreen.

This bug is started to begin work on tracking the progress of this work.

Link to initial branch work by csharp: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/ubuntu-14-04-makefile

Ben Shum (bshum) on 2014-05-02
Changed in evergreen:
milestone: none → 2.next
importance: Undecided → Wishlist
status: New → Confirmed
Doug Kyle (dkyle) wrote :

The only Makefile change I had to do between Precise and Trusty was to specify 9.3 postgres packages, but I did have to add /usr/lib/x86_64-linux-gnu/dbd/ /usr/lib/x86_64-linux-gnu to $DBI_LIBS in configure.ac.

Chris Sharp (chrissharp123) wrote :

My latest changes to http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/ubuntu-14-04-makefile are ready for testing. I recommend cherry picking the top commits from that branch onto a current master branch - otherwise DB creation will fail because there's not a 9.3 version of the fts-config sql file in that branch.

Chris Sharp (chrissharp123) wrote :

Please test from this branch, where I have already seen corrections to be made:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/ubuntu-14-04-makefile-updated

Chris Sharp (chrissharp123) wrote :

Created a signoff branch: http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/csharp/ubuntu-14-04-makefile-signoff

Adding pullrequest tag so we hopefully get this into 2.7-alpha!

tags: added: pullrequest
Ben Shum (bshum) wrote :

Picked this to master (added a few more changes) and anticipating further work during 2.7 development. Thanks Chris for getting us started!

Changed in evergreen:
milestone: 2.next → 2.7.0-alpha
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers