to remove last remnants of JSPAC

Bug #1312309 reported by Galen Charlton on 2014-04-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

TPac has been the default OPAC mode for several versions now, and no work has been done on JSPAC in terms of bugfixes for at least a year. It's time to remove the last vestiges of JSPAC

Evergreen master

Ben Shum (bshum) wrote :

This is a continuation of bug 1152655's intent to eventually fully remove JSPAC from the code base.

As a note for potential workers of this bug, I remember that ripping out some of the JSPAC CSS had unexpected consequences in the staff client; I think some of the styles are shared there.

Changed in evergreen:
milestone: none → 2.next
status: New → Confirmed
Galen Charlton (gmc) wrote :

There's also some JavaScript that probably originated with JSPac that in use by staff client bits -- for example, I suspect some of the modules used by the closed editor editor falls in this category.

Jeff Godin (jgodin) wrote :

I plan to begin work on a working branch that will remove JSPAC per the stated goals of this bug.

If anyone else has already begun work, please speak up within the next few days, so as to avoid duplication of effort.

Thanks!

Changed in evergreen:
assignee: nobody → Jeff Godin (jgodin)
Jeff Godin (jgodin) wrote :

Working branch is presently user/jeff/remove_jspac_after_bbags

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeff/remove_jspac_after_bbags

The above branch is very much a work in progress subject to rebasing and is presently based off of a working branch that removes an old bookbag/lists interface, which is in turn based off of a branch that removes the legacy self checkout interface.

Jason Stephenson (jstephenson) wrote :

Umm, so what does that branch do, exactly? Does it remove JSPAC, the old bookbag/lists interface, and the legacy self checkout interface all at once? If so, I think it needs to be split up if possible.

Ben Shum (bshum) wrote :

So, it looks like it builds on berick's branch to remove legacy selfcheck, then kills old bbags, then kills off a lot of the JSPAC files.

I've put together a rebased branch here: user/bshum/kill-jspac-rebase

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/kill-jspac-rebase

A note on my rebase, I added the appropriate LP# tags for the commit messages, signed off on everything so far, and then added a new commit to deal with an issue encountered during fresh installation, whereby the Makefile from Open-ILS/web/Makefile was looking to go into some JSPAC folders to do some clean removals/copying. Short-term, it solves the issue and allowed me to cleanly install the whole branch. Long-term, we should probably open a new bug to clean up the Makefiles and avoid copying/creating folders for things we do not need to copy anymore.

tags: added: pullrequest
Changed in evergreen:
milestone: 2.next → 2.9-beta
Bill Erickson (berick) wrote :

I tested Ben's branch and can report no problems. I made sure to poke around the legacy HTML admin interfaces, which borrow jspac code, and all is well there.

Jeff Godin (jgodin) wrote :

Thanks, Ben, Bill!

I've added release notes and pushed to master.

RIP, JSPAC.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Jeff Godin (jgodin) → nobody
tags: removed: pullrequest
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers