time to remove script-based circ policies

Bug #1312308 reported by Galen Charlton on 2014-04-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

From Benjamin Shum's proposal to be RM for 2.7:

    4) Deprecate and remove old code that is no longer necessary or
    broken. As one immediate example: the old style circulation scripts
    have been officially deprecated since version 2.4 in favor of
   in-database circulation policies and we should remove the circ scripts
  completely from the code base along with any other unnecessary pieces

Removing the script-based circ policy support would:

- remove a potential source of bugs and discrepancies with in-DB circ policies
- take us further (or even all the way) towards allowing us to remove the SpiderMonkey dependency, simplifying installation

Potential downsides:

- there may still be libraries depending on functionality that is still only possible with script-based circ policy

Evergreen master

Ben Shum (bshum) on 2014-05-01
Changed in evergreen:
status: New → Confirmed
milestone: none → 2.next
Bill Erickson (berick) wrote :

In progress branch to kill script based circ. Hastily created and lightly tested. Eyes and testing appreciated.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1312308-kill-script-circ

Bill Erickson (berick) wrote :

Rebased and squashed the above branch. Testing on a clean VM now...

Bill Erickson (berick) wrote :

Additional Makefile cleanup fixes en route...

Bill Erickson (berick) wrote :

Another force-push. Successfully installed on fresh VM. Perl tests succeed. Check out / in and holds placement produces no explosions. Slapping a pullrequest on this bad boy.

tags: added: pullrequest
Bill Erickson (berick) wrote :

I went to clean up one more reference to a removed JS script file for open-ils.penalty, but decided instead to remove the entire open-ils.penalty service (configs, mods, etc.), since it has not been used in Evergreen since before version 2.0. (Everything uses Utils::Penalty now).

And.. we'll probably need some upgrade notes. Adding those now.

Bill Erickson (berick) wrote :

Release notes pushed. OK, I'm done now, pending comments, etc.

Jason Stephenson (jstephenson) wrote :

I have tested this branch extensively for the past month or so. Circulation still works.

I have pushed a signoff branch to http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dyrcona/lp1312308-kill-script-circ_signoff

I will push this branch into master over the weekend or early next week unless someone objects strenuously.

With a big change like this, I think it is a good idea to give everyone ample opportunity and warning to look at it.

tags: added: signedoff
Changed in evergreen:
milestone: 2.next → 2.9-alpha
Jason Stephenson (jstephenson) wrote :

Thanks, Bill and everyone else!

Pushed to master.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
milestone: 2.9-alpha → 2.9-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers