validate headings broken in 2.6.0

Bug #1311467 reported by Galen Charlton on 2014-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

The patch for bug 1253163 introduced a regression where clicking the validate button in the bib MARC editor would cause the headings validation check to fail with the following error:

Timestamp: 4/23/2014 12:32:10 AM
Error: Error: Method error: undefined : *** Call to [open-ils.search.authority.simple_heading.from_xml.batch.atomic] failed for session [0.7662197621584221398227212406], thread trace [1]:
Can't use an undefined value as an ARRAY reference at /usr/local/share/perl/5.10.1/OpenILS/Application/Search/Authority.pm line 81.

This is due to two distinct problems:

[1] are.heading and are.simple_heading were not added to fm_IDL.xml
[2] the "startwith" JSON query operator is defined only for transform predicates, and in the revamped query on authority.record_entry, gets passed through as is instead of being transformed to LIKE foo || '%'

Evergreen 2.6.0

Galen Charlton (gmc) wrote :

A patch to fix this is available in the user/gmcharlt/lp1311467_fix_heading_validation branch in the working/Evergreen repository:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1311467_fix_heading_validation

tags: added: authority cataloging pullrequest
Mike Rylander (mrylander) wrote :

Looks good. Picked into master and 2.6. Thanks, Galen!

Changed in evergreen:
status: New → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers