Z39.50 Local Catalog Search Needs "Staff" Flag

Bug #1310283 reported by Jason Stephenson on 2014-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Evergreen version 2.6.0 && master as of 20140416
OpenSRF version 2.3.0 or master
PostgreSQL version 9.1.13

Since upgrading to 2.6.0, new bibliographic records (i.e. added since the upgrade) do not show up in Z39.50 search if local catalog is selected.

You can reproduce this by adding a new bibliographic record, volume, and copy. Then go to Z39.50 search, check off local catalog and any other sources you like, and then search for that new record's ISBN, title, or whatever. The new record in the catalog does not show up. There is no entry in the results for native evergreen catalog.

If you search for records that existed prior to the upgrade, then those records do show up. This only seems to affect records added to the database since the upgrade.

I have not checked but I suspect this also affects SRU record display.

Thomas Berezansky (tsbere) wrote :

Looks like this is actually a different problem, and the testing that implied "new records" was faulty.

The real issue is that Z39.50 searches of the local catalog are losing their "staff" flag, and the initial testing that led to this involved records without copies or with copies owned by an opac-invisible org unit.

The branch below seems to correct this issue in my testing. I am unsure as to how far back this issue actually goes, though.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/tsbere/z3950_staff_search

Thomas Berezansky (tsbere) wrote :

After more digging this looks to only be a problem in 2.6 and master.

Ben Shum (bshum) wrote :

Renaming bug title to something more on point and marking initial fix target for 2.6.1. Sounds like when we ripped out the quest for knowledge, it broke this?

summary: - New Records Do Not Showup in Z39.50 Local Catalog Search
+ Z39.50 Local Catalog Search Needs "Staff" Flag
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 2.6.1
tags: added: pullrequest
Ben Shum (bshum) wrote :

Works for me, pushed to master and rel_2_6. Thanks tsbere!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers