add sample RDA records to test data set

Bug #1308768 reported by Yamil on 2014-04-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

This bug was thought of by Dan Scott.

In order to properly write code for RDA support we need to have good RDA records in the test data set. As part of a U.S. based library I was able to go in a grab RDA records from LoC by using this link...

http://catalog.loc.gov/cgi-bin/Pwebrecon.cgi?DB=local&PAGE=First

I used their "expert search"

with a query of "040e rda"

then used various "search limits" of "type"

I will soon add a collab branch where I submit some RDA records.

Yamil (ysuarez) wrote :

Here is the collab branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/ysuarez/lp1308768_sample_RDA_records_from_loc

Here are the 4 record filenames, plus the available LoC permalinks to them:

RDA_record_MAP_2012_Enchanted_Circle.mrc
http://lccn.loc.gov/2013585177

RDA_record_DVD-BLUE-RAY-MOVIE_Pineapple_express.mrc
http://lccn.loc.gov/2010600022

RDA_record_PHOTO_Srid_pa_ho.mrc
http://lccn.loc.gov/2011432135

RDA_record_SERIAL_IEEE_International_conference.mrc

I originally found more than 4 RDA records, but it was pointed out that they were
using older/outdated versions of RDA. For example, the records used the 260
tag instead of using the 264 tag.

Dan Scott (denials) wrote :

This is a great start, Yamil!

I signed off on Yamil's commit and provided a conversion of the records into the loadable format required by "eg_db_config --load-all" at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbs/lp1308768_sample_RDA_records_from_loc

I also added the "LP# 1308768" prefix to the commit log summary line.

Yamil (ysuarez) wrote :

I just made a new collab branch with 6 more RDA records from LC.

Here is the branch URL:

 http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/ysuarez/lp1308768_sample_RDA_records_from_loc_02

Here is the commit message:

Second set of test RDA records from LC - 6 total

Here is another batch of test records from LC from this site:

http://catalog2.loc.gov/vwebv/searchKeyword
http://catalog.loc.gov/vwebv/searchKeyword

Here are links to the MARCXML versions of the files. Search for files with

XML records with 264 and ind2 set to _1 and _4
http://lccn.loc.gov/2014340080/marcxml - DVD - Jorge Mautner
http://lccn.loc.gov/2013335283/marcxml - CD - Claudia
http://lccn.loc.gov/2013493195/marcxml - SCORE - Wiegenlied

XML with 264 and ind2 set to _1 and _2
http://lccn.loc.gov/2013565186/marcxml - SCORE - Arias for bass
http://lccn.loc.gov/2013565190/marcxml - SCORE-CD - Arias for soprano

XML with 264 and ind2 set to _1 _2 and _4
http://lccn.loc.gov/2013568403/marcxml - SCORE - Intermediate_studies

Ind2 values key:
0 - Production
1 - Publication
2 - Distribution
3 - Manufacture
4 - Copyright notice date

I added both MARCXML and UTF8 MARC files for each record.

RDA_record_DVD_Jorge_Mautner
RDA_record_CD_Claudia
RDA_record_SCORE_Wiegenlied
RDA_record_SCORE_Arias_for_bass
RDA_record_SCORE-CD_Arias_for_soprano
RDA_record_SCORE_Intermediate_studies

Ben Shum (bshum) wrote :

Updating this bug to target it towards 2.next. We should review and get it included for 2.7 to help test RDA work.

Changed in evergreen:
milestone: none → 2.next
status: New → Confirmed
importance: Undecided → Wishlist
Yamil (ysuarez) wrote :

Last time Dan converted my raw MARC files into a format that eg_db_config --load-all-sample could use. I can try to process the 6 new files in a similar way, though I might not get it right the first time. Though if someone is more familiar with the process, feel free to give it a go.

Ben Shum (bshum) on 2014-08-07
Changed in evergreen:
milestone: 2.next → 2.7.0-beta1
Dan Scott (denials) wrote :

Force pushed a fix to the corrupted XML that Ben Shum noticed.

Dan Scott (denials) wrote :

And updated with a signed-off version of Yamil's bibs (removing the XML variants because they are trivially recreatable from the MARC21 binary), as well as an updated rda_bibs.sql file that will load the additional files at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbs/lp1308768_sample_RDA_records_from_loc

Ben Shum (bshum) wrote :

Pushed to master. Yay sample data!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers