Small documentation linking bugs

Bug #1294347 reported by Remington Steed
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Undecided
Unassigned

Bug Description

This bug lists a number of places where the documentation uses hard-coded AsciiDoc links ("link:file_name.txt[Click here]"), where it would be better to use AsciiDoc cross references ("xref:my-section-id[Click here]"). This is probably an intermediate level docs bug, since it requires finding the section-id in the published docs (look inside the section heading for the "<a id=" tag; you want the value of the id attribute). This bug also requires testing of the docs after they are built and published overnight. For more information on link syntax, see the "Linking" section of the Evergreen documentation style guide:
http://evergreen-ils.org/dokuwiki/doku.php?id=evergreen-docs:dig_style_guide&#linking

Here are the bugs
-----------------

acquisitions/introduction.txt:
"(see link:../installation/edi_setup.txt[Setting Up EDI Acquisitions] under Software Installation)"

acquisitions/introduction.txt:
"(see link:../cataloging/batch_importing_MARC.txt[Batch Importing MARC Records] in Cataloging)"

acquisitions/selection_lists_po.txt:
"when you link:brief_records.txt[Add Brief Records], or...through the link:federated.txt[MARC Federated Search]"

acquisitions/selection_lists_po.txt:
"one of three ways: link:brief_records.txt[add a brief record]; upload MARC order records; add records through a link:federated.txt[federated search]; or use the link:federated.txt[View/Place Orders] menu item in the catalog."

acquisitions/selection_lists_po.txt:
"See the section on link:03~PO.txt[purchase orders] for more information."

acquisitions/selection_lists_po.txt:
"See the link:line_items.txt[section on Line Items] for more information."

acquisitions/selection_lists_po.txt:
"See the link:line_items.txt[section on Line Items] for more information."

admin/acquisitions_admin.txt:
"also the link:../installation/edi_setup.txt[EDI Installation Instructions]"

circulation/holds.txt:
"see the link:_managing_holds.html#_actions_for_selected_holds[Actions for Selected Holds] section."
(Note: With "xref" syntax, you can link directly to the section, so this will probably become "xref:_actions_for_selected_holds[Actions for Selected Holds]".)

serials/A-intro.txt:
"link:_generate_prediction.html[explained here]"

serials/B-copy_template.txt:
"see the chapter on link:_floating_groups.html[Floating Groups]."

serials/C-subscription-SCV.txt:
"see link:_creating_a_stream.html[Creating a Stream]."

serials/D-subscription-ASCV.txt:
"See link:_alternate_serial_control_view.html#_creating_a_subscription[] for more information."

Remington Steed (rjs7)
tags: added: documentation
Changed in evergreen:
assignee: nobody → Josh Stompro (u-launchpad-stompro-org)
Revision history for this message
Kathy Lussier (klussier) wrote :

Hi Josh,

I noticed you assigned yourself to this bug, but the fix was actually just pushed into the master earlier this week. Looks like we forgot to update the LP bug. I'll do so now.

Kathy

Revision history for this message
Kathy Lussier (klussier) wrote :

Sorry - I take that back. Looks like I'm confussing this commit - http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=31f54c79f907b80c26aa7b78bc9c2052a58d15a0 - with this bug.

Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :

Can someone help me figure out where exactly the following link should go?

"or use the link:federated.txt[View/Place Orders] menu item in the catalog."

It's on http://docs.evergreen-ils.org/dev/_selection_lists_and_purchase_orders.html#_selection_lists

I cannot tell where the view/Place Orders menu item in the catalog is documented to try and link to it.

Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :

Pull request created - https://github.com/evergreen-library-system/Evergreen/pull/23

I fixed every link except one, the one I asked about earlier. I did some testing with a local build of the docs and it seemed to work just fine.

Josh

tags: added: pullrequest
Changed in evergreen:
status: New → In Progress
Revision history for this message
Remington Steed (rjs7) wrote :

Hi Josh,

Thanks for your work on this. I believe the Evergreen community uses the "in progress" bug status as "waiting for someone to submit some code". So since you already have a pull request, I have changed the status. I have also removed you from the "assigned to" field, so that others will know it is ready for their attention. Again, thanks for your contributions!

Remington

Changed in evergreen:
status: In Progress → Confirmed
assignee: Josh Stompro (u-launchpad-stompro-org) → nobody
Revision history for this message
Kathy Lussier (klussier) wrote :

In answer to your question from the other night, I think removing the link was the correct thing to do. I don't see any other documentation that makes mention of the View/Place Orders action.

Remington Steed (rjs7)
Changed in evergreen:
status: Confirmed → Fix Released
milestone: none → 2.next
milestone: 2.next → 2.7.1
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers