Embedded TPAC 'Place Hold' button fails to activate on load

Bug #1294156 reported by Bill Erickson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Evergreen 2.6+

In the staff client, load a patron, go to Holds, click Place Hold, perform a TPAC search, chose Place Hold on a record. In the holds form that displays, the 'Place Hold' button is disabled, even though the staff client provided a valid barcode on load.

This bug was recently introduced with http://git.evergreen-ils.org/?p=Evergreen.git;a=commit;h=b055fe4

Fix en route...

Revision history for this message
Bill Erickson (berick) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Bill Erickson (erickson-esilibrary) → nobody
Revision history for this message
Erica Rohlfs (erohlfs) wrote :

I confirmed this behavior. However, the fix Bill offers also takes care of the bug. The functionality runs a lot smoother, and the Place Hold button is no longer disabled for a valid barcode.

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Ben Shum (bshum) wrote :

Tested and works for me. Pushed to master.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers