Remove unused function get_leaders_from_usergroup

Bug #1289534 reported by Remington Steed on 2014-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.6
Low
Unassigned

Bug Description

The perl function get_leaders_from_usergroup was found to be buggy and unused anywhere in the codebase. Let's remove unused code, rather than worry about maintenance and upkeep. Here's the branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/remove_unused_usergroup_leaders_function

working/user/rsteed/remove_unused_usergroup_leaders_function

From the commit message:

Remove buggy, unused function get_leaders_from_usergroup

Recent editing and testing of get_leaders_from_usergroup() uncovered an
unrelated bug which renders the function useless (it returns all group
members, not just the leader). It wasn't previously caught because
Evergreen has no apparent references to this function. This commit
removes the unused function.

Revision history for this message
Dan Wells (dbw2) wrote :

Just to add to the conversation, commit 2ea32b916f suggests that this was perhaps committed accidentally some 8 years ago. As Remington says, it isn't used anywhere. I support yanking it out, but want to give others time to comment.

Also, looks like LP#1281750 needs to go in first for this branch (as well it should).

Changed in evergreen:
milestone: none → 2.6.0-rc1
importance: Undecided → Low
status: New → Confirmed
Changed in evergreen:
milestone: 2.6.0-rc1 → 2.next
Revision history for this message
Dan Wells (dbw2) wrote :

Dead code should die. Thanks, Remington.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Ben Shum (bshum) on 2014-07-23
Changed in evergreen:
milestone: 2.next → 2.7.0-alpha1
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers