TPAC - CSS for advanced search filters

Bug #1287973 reported by Ben Shum on 2014-03-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned

Bug Description

Evergreen master

As of http://git.evergreen-ils.org/?p=Evergreen.git;a=commitdiff;h=161815ed45e1eb468ddf342af25cf64b1bd80a94 , the clear: both; part of the CSS for adv_filter_block is commented out. This leads to a situation where if there's enough room on your browser to display both groups of advanced search filters, they appear as a single row of filters and not two distinct rows of filters. Removing the comment and reinstating the original CSS repairs this and breaks it back up into separate rows as expected.

Was there a reason we commented out this part of the CSS? Or was it just something that snuck into the code as other work on WCAG improvements went on?

I can whip up a tiny fix to put this back the way it was if there's no reason it's intentionally been changed.

Revision history for this message
Bill Erickson (berick) wrote :

Arg, I believe that was leftover from an experiment. I've confirmed the page behaves as expected with the clear:both is recovered. Fix pushed:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp-1287973-tpac-adv-filter-clear

Thanks for tracking that down, Ben.

Changed in evergreen:
status: New → Confirmed
milestone: none → 2.6.0-rc1
tags: added: opac pullrequest
Revision history for this message
Ben Shum (bshum) wrote :

Thanks Bill! Pushed to master for 2.6-rc1.

Changed in evergreen:
status: Confirmed → Fix Committed
importance: Undecided → Low
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers