Problems with 0864.MVF_CRA-upgrade.sql and reporter.classic_current_circ

Bug #1287967 reported by Ben Shum on 2014-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned

Bug Description

Evergreen master

When attempting to run 0864.MVF_CRA-upgrade.sql (and presumably a problem in the upgrade SQL for 2.5-2.6 too), it will fail to run if your system makes use of the custom reporter.classic_current_circ view, which depends on metabib.rec_descriptor (which is one of the views dropped and recreated with 0864).

The "solution" is likely to consist of the following:

1) Put a DROP VIEW IF EXISTS reporter.classic_current_circ; before the DROP VIEW metabib.rec_descriptor; in the script. And then make a note somewhere about running the example reporter scripts to recreate this later.

2) Rewrite the reporter.classic_current_circ view to use a different way of getting that information.

Note discussion from IRC logs: http://irc.evergreen-ils.org/evergreen/2014-03-04#i_74089

Patch and ideas forthcoming, but this should be resolved before we release 2.6-rc1

Revision history for this message
Ben Shum (bshum) wrote :

Only changing the 0864 file since it will fail to apply completely if this issue is encountered.

Fix here: user/bshum/lp1287967-fix-0864-upgrade

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/lp1287967-fix-0864-upgrade

tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.6.0-rc1
importance: Undecided → High
status: New → Confirmed
Bill Erickson (berick) on 2014-03-13
Changed in evergreen:
assignee: nobody → Bill Erickson (erickson-esilibrary)
status: Confirmed → In Progress
Revision history for this message
Bill Erickson (berick) wrote :

Confirmed the issue and the fix. In addition to my sign-off, I pushed a small change to the release notes for composite-attr-defs to mention the lost view there as well (belt + suspenders).

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1287967-fix-0864-upgrade-continued

Changed in evergreen:
assignee: Bill Erickson (erickson-esilibrary) → nobody
status: In Progress → Confirmed
Revision history for this message
Ben Shum (bshum) wrote :

Oh good call Bill on the release note addition. Done and pushed to master, with thanks!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers