Staff Client workstation search preferences are not used after the search location is modified

Bug #1282301 reported by Liam Whalen
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

When setting search location preferences in the staff client, if the default search location is changed, the search location remains as the new location rather than returning to the preference selected.

Evergreen 2.4.0
OpenSRF 2.2.0
PostgreSQL 9.1
Ubuntu 12.04

In the Staff Client

Admin -> Workstation Administration -> Set Search Preferences

note the value of the default search library

Search -> Search the Catalog

change the 'Search Library' to a value other than the one set for the workstation.

conduct a search.

open a new tab

Search -> Search the Catalog

the search library remains the newly chosen search library instead of the default search library.

Ideally, when a new tab is opened the search library will be set to the default search library.

In cases where the search terms remain or the type of search is changed (from basic to advanced for example) the current search library should be retained.

Revision history for this message
Liam Whalen (whalen-ld) wrote :

I am working on a fix for this. I will integrate it into master with the hopes of having it included in 2.6-rc1.

Changed in evergreen:
assignee: nobody → Liam Whalen (whalen-ld)
Dan Wells (dbw2)
Changed in evergreen:
milestone: none → 2.6.0-rc1
Revision history for this message
Liam Whalen (whalen-ld) wrote :
tags: added: pullrequest
Liam Whalen (whalen-ld)
Changed in evergreen:
assignee: Liam Whalen (whalen-ld) → nobody
Changed in evergreen:
milestone: 2.6.0-rc1 → 2.next
Revision history for this message
Erica Rohlfs (erohlfs) wrote :

Hi Liam!

As part of Bug Squashing Day today, I tested this bug and the fix. As the bug is described, I could not reproduce the behavior. When I set a search preference within the staff client, Evergreen is recognizing my Default Search Library regardless of any changes to the catalog scoping.

However, I am seeing the behavior that you describe of Evergreen not retaining a patron's search preference within the patron OPAC. To recreate the behavior, log into the Patron OPAC. Select Account Preferences -> Search and History Preferences -> select your preferred library within the Preferred Search Location dropdown. Next, conduct an OPAC search and scope to a different Search Library. When the patron conducts another search, Evergreen will retain the last library scoped and not default back to the patron's preferred search library.

Liam's fix does fix the behavior that I am seeing in the OPAC.

Again, however, I cannot recreate the error as described above within Workstation Admin and within staff client opac.

Revision history for this message
Erica Rohlfs (erohlfs) wrote :

I need to retract my statement. In further testing of the OPAC, Evergreen is retaining the last library that I scoped to within my search (and I would think that this is expected behavior).

So, I guess I'll just leave it at the fact that I cannot confirm the bug to successfully test the fix.

Revision history for this message
Kathy Lussier (klussier) wrote :

I also was unable to replicate the behavior reported in the bug. I'm going to remove the pullrequest tag and set the status of the bug to Incomplete. If anyone can confirm the bug, let us know and we can take another look at it.

tags: removed: pullrequest
Changed in evergreen:
status: New → Incomplete
Galen Charlton (gmc)
Changed in evergreen:
milestone: 2.next → none
no longer affects: evergreen/2.6
no longer affects: evergreen/2.7
Changed in evergreen:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers