MARC edit no save data warning when leaving a record

Bug #1282277 reported by Liam Whalen
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
2.6
Undecided
Unassigned
2.7
Undecided
Unassigned

Bug Description

When editing a MARC record, if users make edits then change to new screens, such as the OPAC view, they will be given a warning that they might lose data.

If they click OK on that warning then they are taken to the new screen. If they then return to the MARC editor, their changes will still be present, but if they change to a different screen a second time they will not be given a lose data warning message.

Evergreen 2.4.0
OpenSRF 2.2.0
PostgreSQL 9.1
Ubuntu 12.04

In the staff client

Search -> Search the Catalog
enter a search term and submit the search
click on a record in the search results
Actions for this Record -> MARC Edit
edit a field and add or remove multiple characters
Actions for this Record -> OPAC View
click ok on the warning that appears
Actions for this Record -> MARC Edit
verify that your changes are still present
Actions for this Record -> OPAC View

no warning is presented, the user is take directly to the OPAC view

The users should be prompted again that they will lose data

Revision history for this message
Liam Whalen (whalen-ld) wrote :

I have a fix for this, and I am going to integrate it into master. Hopefully, it can be added to the rc1 release.

Revision history for this message
Liam Whalen (whalen-ld) wrote :
Changed in evergreen:
assignee: nobody → Liam Whalen (whalen-ld)
Liam Whalen (whalen-ld)
description: updated
Dan Wells (dbw2)
Changed in evergreen:
milestone: none → 2.6.0-rc1
Revision history for this message
Liam Whalen (whalen-ld) wrote :
tags: added: pullrequest
Revision history for this message
Kyle Tomita (tomitakyle) wrote :

Reviewing this card with https://bugs.launchpad.net/evergreen/+bug/1282286 since the commit is together. Please see that card for status of testing.

Revision history for this message
Kyle Tomita (tomitakyle) wrote :
tags: added: signedoff
Liam Whalen (whalen-ld)
Changed in evergreen:
assignee: Liam Whalen (whalen-ld) → nobody
Changed in evergreen:
milestone: 2.6.0-rc1 → 2.next
Revision history for this message
Liam Whalen (whalen-ld) wrote :

There is an bug in this code that cause duplicate records to be created when performing Cataloguing -> Create New MARC Record. It also creates a UI bug when importing via Cataloguing -> Import Record from Z39.50.

I am working on fixing this.

Revision history for this message
Liam Whalen (whalen-ld) wrote :

The updates for this fix can be found here:

https://bugs.launchpad.net/evergreen/+bug/1282286

Revision history for this message
Liam Whalen (whalen-ld) wrote :
Kathy Lussier (klussier)
tags: removed: signedoff
Revision history for this message
Kathy Lussier (klussier) wrote :

Marking this one as a duplicate of https://bugs.launchpad.net/evergreen/+bug/1282286 since all of the code is meged on to the branch posted there. Thanks Liam!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers