Support vandelay import match strategies in marc_stream_importer

Bug #1279998 reported by Bill Erickson on 2014-02-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

From the commit:

Adds support for sending auto-overlay-1match and auto-overlay-best-match in addition to auto-overlay-exact to Vandelay when performing imports. If no strategy is chosen, the script still defaults to auto-overlay-exact.

These changes are managed with 3 new command line options:

--auto-overlay-exact
--auto-overlay-1match
--auto-overlay-best-match

===

Without this addition, marc_stream_importer.pl only supports exact-match (auto-overlay-exact) imports.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/marc-stream-importer-match-strategy

Bill Erickson (berick) wrote :

Pushed another commit to support --import-no-match, which was previously assumed to always be true.

Ben Shum (bshum) on 2014-02-16
Changed in evergreen:
status: New → Triaged
Martha Driscoll (mjdriscoll) wrote :

NOBLE has been using this version of marc_stream_imorter.pl to load electronic resource marc records into our production system. We are able to split large files into 500-record chunks and then use a shell script to invoke marc_stream_importer for each file. It's great to have a command-line alternative to Vandelay when you want to load files hands-off.

Ben Shum (bshum) wrote :

If Martha is successfully testing this at her site, maybe she can help with the signoff on this work. Maybe later this week.

Though, marking "incomplete" because I think we need release notes for this new feature.

Changed in evergreen:
status: Triaged → Incomplete
tags: added: needsreleasenote
Bill Erickson (berick) wrote :

Release notes pushed. Commits updated with LP#.

Changed in evergreen:
status: Incomplete → Confirmed
tags: removed: needsreleasenote
Changed in evergreen:
milestone: 2.6.0-rc1 → 2.next
Kathy Lussier (klussier) wrote :

As Martha mentioned above, NOBLE has been successfully using this in production for months. Adding my signoff at:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/marc-stream-importer-match-strategy

Ben Shum (bshum) wrote :

Great, thanks Martha and Kathy!

Pushed to master (with a tiny formatting change for the release note entry)

Changed in evergreen:
milestone: 2.next → 2.7.0-beta1
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers