User editor cloned address owner link fails to load new tab

Bug #1261777 reported by Bill Erickson on 2013-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.5
Undecided
Unassigned
2.6
Undecided
Unassigned
2.7
Undecided
Unassigned

Bug Description

Evergreen 2.4+

Open Register Patron, fill in the necessary patron reg. data, then click Save and Clone. Assuming you are not copying cloned addresses (via org setting), the cloned address will show a link to the address owner. Clicking on the link does nothing.

I've tracked this down to a JS error. Patch forthcoming.

This is an odd bug, though, because it does not always happen. It's confirmed on a 2.4 and a 2.5 server, but not on a master server, even though the offending code is the same.

Bill Erickson (berick) wrote :
tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.5.2
Dan Wells (dbw2) on 2014-01-17
Changed in evergreen:
milestone: 2.5.2 → 2.6.0-alpha1
Dan Wells (dbw2) on 2014-02-05
Changed in evergreen:
milestone: 2.6.0-alpha1 → 2.6.0-beta1
Ben Shum (bshum) wrote :

Alright, so I applied that change to one of my staff clients connect to a master server as of 2014-02-13 and the name that gets linked still doesn't start up a new tab with the change specified. It looks like it should be a simple client side change, but maybe there's more to this than meets the eye.

Will try installing from scratch and building a fresh client, just to be sure...

Ben Shum (bshum) on 2014-02-16
Changed in evergreen:
status: New → Incomplete
importance: Undecided → Medium
Dan Wells (dbw2) on 2014-02-27
Changed in evergreen:
milestone: 2.6.0-beta1 → 2.6.0-rc1
Changed in evergreen:
milestone: 2.6.0-rc1 → 2.next
no longer affects: evergreen/2.4
Ben Shum (bshum) wrote :

Pushed to master, rel_2_7, and rel_2_6.

Changed in evergreen:
status: Incomplete → Fix Committed
Changed in evergreen:
milestone: 2.next → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers