'TypeError: obj.active_services is undefined' error when entering z39.50 MARC import UI

Bug #1243280 reported by Chris Sharp on 2013-10-22
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.5
Medium
Unassigned

Bug Description

On 2.5-beta1, when entering the Cataloging -> Import Record from Z39.50 interface, an alert box pops up with the following error:

TypeError: obj.active_services is undefined

No corresponding messages in the JavaScript console that I was able to see.

Ben Shum (bshum) wrote :

Marking confirmed since I saw this on some recent master/2.5 builds as well. Will test further, also didn't see any Javascript errors in my initial looking

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Jason Stephenson (jstephenson) wrote :

We see this also at MVLC.

Jason Stephenson (jstephenson) wrote :

This may or may not be related.

When I check the javascript console after opening the import records via z39.50 interface, I see several of these messages:

Timestamp: 12/10/2013 02:52:51 PM
Warning: Empty string passed to getElementById().
Source File: oils://remote/xul/rel_3_0_20131206_120120/server/OpenILS/global_util.js
Line: 354

Jason Stephenson (jstephenson) wrote :

The above is not actually related to this problem, but I made a commit to get rid of that console message since it was bothering me while looking at this problem.

I have a branch that potentially addresses this issue at

working/user/dyrcona/lp1243280_z3950_active_services

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dyrcona/lp1243280_z3950_active_services

tags: added: cataloging pullrequest z3950
Jason Stephenson (jstephenson) wrote :

Feel free to only cherry-pick the last commit if you're uncomfortable adding the fix for the spurious console warning.

Ben Shum (bshum) wrote :

Works fine for me, tested the z39.50 one and also the miscellaneous extra console error.

Picked to master and rel_2_5.

Thanks Jason!

Changed in evergreen:
status: Confirmed → Fix Committed
Ben Shum (bshum) on 2014-02-16
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers