MARC batch import/export interface doesn't always load variables

Bug #1227667 reported by Ben Shum on 2013-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

So, periodically, we've seen the MARC batch import/export interface fails to load all the variables. Specifically, we saw that it would fail to load the record match set, bucket lists, holdings import profiles, and record source.

In the Javascript console, we saw the following error when this occurred:

Timestamp: 09/19/2013 09:39:29 AM
Error: TypeError: allUserBibQueues is undefined
Source File: oils://remote/js/ui/default/vandelay/vandelay.js
Line: 1457

Bill Erickson at the Hack-A-Way helped us pinpoint the problem to a change necessary in vandelay.js bumping var initNeeded = 9; to 10; instead.

More details and branch forthcoming.

Ben Shum (bshum) wrote :

For note, this affected us on most recent master. Not sure if it affects any previous versions or not, but I doubt it.

tags: added: cataloging vandelay
Changed in evergreen:
status: New → Triaged
importance: Undecided → Medium
Ben Shum (bshum) wrote :

Bill pushed a branch with the fix. It works for me and only seems to be an issue in master.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/vandelay-ui-load-missing-async-item

Picked to master, thanks Bill!

Changed in evergreen:
milestone: none → 2.5.0-beta1
status: Triaged → Fix Committed
Dan Wells (dbw2) on 2013-11-11
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers