TPAC "my list" still referred to as "bookbag" in some places

Bug #1210161 reported by Remington Steed on 2013-08-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

The TPAC renamed "bookbags" to "lists". Most "bookbag" occurrences are in URL parameters and logs, but a few are more prominent. We should at least correct the following:

src/templates/opac/myopac/lists.tt2
369:[% |l %]Sharing a Bookbag means that the contents
370:of the Bookbag will be visible to others.
371:To see the public view of a shared Bookbag,
372:click on the Bookbag's name in the Bookbag list.[% END %]

src/templates/opac/parts/anon_list.tt2
35:<optgroup label="[% l('Move selected items to bookbag:') %]">
-- Visible in TPAC via: login, add item to temporary list, go to My Account > My Lists, under Temporary List click dropdown Actions for these items, in bold: "Move selected items to bookbag".

src/templates/opac/parts/record/body.tt2
11:[% l("This record has been deleted from the database. We recommend that you remove this title from any bookbags it may have been added to.") %]

src/sql/Pg/950.data.seed-values.sql
4967:INSERT INTO container.biblio_record_entry_bucket_type (code,label) VALUES ('bookbag', oils_i18n_gettext('bookbag', 'Book Bag', 'cbrebt', 'label'));
-- No longer used?

src/sql/Pg/950.data.seed-values.sql
10272:'Produce a CSV file representing a bookbag',

src/sql/Pg/950.data.seed-values.sql
10284:'Facilitates produce a CSV file representing a bookbag by introducing an "items" variable into the TT environment, sorted as dictated according to user params',
-- can we change this wording while we are here? "Facilitates producing" maybe?

src/sql/Pg/950.data.seed-values.sql
10296:'Bookbag CSV', 'container.biblio_record_entry_bucket.csv', 'ContainerCSV',

src/sql/Pg/950.data.seed-values.sql
12057:'Present a warning dialog to the patron when a patron adds a book to a temporary book bag.',
-- Adds a row to config.org_unit_setting_type with this description, but the corresponding label says "book list" instead of "book bag".

src/sql/Pg/950.data.seed-values.sql
12093:'Default list to use when adding to a bookbag',
-- also at line 12099

Remington Steed (rjs7) on 2013-08-08
description: updated
description: updated
Ben Shum (bshum) on 2013-11-06
Changed in evergreen:
status: New → Confirmed
milestone: none → 2.next
Remington Steed (rjs7) wrote :

I have pushed a branch to address all of the above occurrences of "bookbag". Comments are welcome.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/finish_renaming_bookbag_to_list

user/rsteed/finish_renaming_bookbag_to_list

Changed in evergreen:
milestone: 2.next → 2.5.1
tags: added: pullrequest
Ben Shum (bshum) on 2013-12-06
Changed in evergreen:
milestone: 2.5.1 → 2.5.2
importance: Low → Medium
Melissa Ceraso (mceraso) wrote :

I'm going to take a look at this.

Changed in evergreen:
assignee: nobody → Melissa Ceraso (mceraso)
status: Confirmed → In Progress
Dan Wells (dbw2) on 2014-01-17
Changed in evergreen:
milestone: 2.5.2 → 2.6.0-alpha1
Dan Wells (dbw2) on 2014-02-05
Changed in evergreen:
milestone: 2.6.0-alpha1 → 2.6.0-beta1
Ben Shum (bshum) wrote :

We started reviewing this and noticed that with some recent changes in master, it no longer applied cleanly when cherry-picking (the message in lists.tt2 moved positioning).

Also, missing an upgrade script to apply the seed data changes?

Changed in evergreen:
status: In Progress → Incomplete
assignee: Melissa Ceraso (mceraso) → nobody
Remington Steed (rjs7) on 2014-02-12
Changed in evergreen:
assignee: nobody → Remington Steed (rjs7)
status: Incomplete → In Progress
Remington Steed (rjs7) wrote :

Rebased to master, resolved the conflict, added an upgrade script and force pushed to the same branch. Thanks for reviewing, Ben!

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/rsteed/finish_renaming_bookbag_to_list

user/rsteed/finish_renaming_bookbag_to_list

Changed in evergreen:
assignee: Remington Steed (rjs7) → nobody
status: In Progress → Confirmed
Ben Shum (bshum) wrote :

Thanks Remington! Looks good at surface glance. My only concern is the part of the upgrade script where we replace the template for Bookbag CSV. I'd be concerned about what if someone had modified their own template for different information. Us replacing it wholesale would potential break that.

I think in the past, some folks have done some special replace commands to change a few words in a template, rather than copying the whole thing. Maybe we can use something like that here. I'll try to find some examples to work off from.

Ben Shum (bshum) wrote :

Unrelated, taking off the 2.5 milestone target since it affects string changes again and backporting those might not be good.

no longer affects: evergreen/2.5
Dan Wells (dbw2) on 2014-02-27
Changed in evergreen:
milestone: 2.6.0-beta1 → 2.6.0-rc1
Changed in evergreen:
milestone: 2.6.0-rc1 → 2.next
no longer affects: evergreen/2.6
Remington Steed (rjs7) wrote :

I force pushed to my above branch to follow Ben's recommendation. Now it simply replaces "bookbag" with "book list" in the template, rather than replacing the whole template.

Ben Shum (bshum) wrote :

Thanks Remington! This has been picked to master for inclusion in 2.7.

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: 2.next → 2.7.0-alpha
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers