attempt to renew in TPAC can result in an Apache internal server error

Bug #1205492 reported by Galen Charlton on 2013-07-26
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.10
Medium
Unassigned
2.9
Medium
Unassigned

Bug Description

Attempting to renew an item that requires a rental or deposit in TPAC will result an an Apache internal server error. The corresponding log entry is:

egweb: template error: undef error - No field by the name fail_part in Fieldmapper::asset::copy! at /usr/local/share/perl/5.10.1/OpenILS/Utils/Fieldmapper.pm line 284.\n, referer: https://example.org/eg/opac/myopac/circs

The myopac/circs.tt2 template contains references to circ.renewal_response.payload.fail_part; this is a problem because the payload of an event response from open-ils.circ.renew is a asset::copy object, not a hash that might contain a fail_part key -- at least when the ITEM_RENTAL_FEE_REQUIRED or ITEM_DEPOSIT_REQUIRED events are returned. I haven't yet verified what the payload looks like if the renewal fails because of (say) a failure to find a matching circ matrix entry.

Evergreen 2.3+

Ben Shum (bshum) on 2014-02-16
Changed in evergreen:
status: New → Triaged
importance: Undecided → Medium
Galen Charlton (gmc) on 2016-08-09
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) on 2016-08-24
Changed in evergreen:
milestone: none → 2.11-beta
status: Triaged → Confirmed
Galen Charlton (gmc) wrote :

A patch is available at the tip of the user/gmcharlt/lp1205492_graceful_rental_renew_handling_in_tpac branch in the working repository:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1205492_graceful_rental_renew_handling_in_tpac

tags: added: pullrequest
Mike Rylander (mrylander) wrote :

Picked into rel_2_9 - master. Thanks, Galen!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers