Firefox dislikes some TPAC stylesheet elements

Bug #1205190 reported by Dan Scott on 2013-07-26
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

* Evergreen master

Peeking at the Firefox Web Console today, I noticed a number of warnings relating to CSS declarations that Firefox no longer supports, as well as some outright CSS errors, and some (in retrospect), CSS non-best practices going on.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbs/tpac_css_cleanup is a quick attempt to address many of those that I ran across. I took care to ensure that anything I removed was not still required by Firefox 14 (to match our staff client version).

Pasi Kallinen (paxed) wrote :

Updated my branch to master, and signedoff Dan's commit on top of that.

tags: added: pullrequest
Ben Shum (bshum) wrote :

Assigning target for 2.5.1 (next bug fix release). We may want to rebase the work given all the various changes made for mobile cat and others.

Changed in evergreen:
milestone: none → 2.5.1
importance: Undecided → Medium
status: New → Confirmed
Ben Shum (bshum) wrote :

Marking incomplete pending new rebase to clean master.

Changed in evergreen:
status: Confirmed → Incomplete
tags: added: css opac tpac
removed: pullrequest
Ben Shum (bshum) on 2013-12-06
Changed in evergreen:
milestone: 2.5.1 → 2.5.2
Dan Wells (dbw2) wrote :

Removed milestone, but re-added pullrequest so that this doesn't get completely lost.

Changed in evergreen:
milestone: 2.5.2 → none
tags: added: pullrequest
Bill Erickson (berick) wrote :

If we can get a master rebase to resolve various conflicts, I'll merge this into our bug-squashing-day test branch for review.

Jim Keenan (jkeenan) wrote :

EG 2.8.4 in C/W MARS

The two warnings that show up for me in the Firefox Web Console are:

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/

and

Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead

Both are generated by the dojo.js file so I'm guessing this will not go away until we're set with dojo.

Galen Charlton (gmc) on 2017-05-15
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

I've rebased against master and added a follow-up patch of my own. New branch is:

user/gmcharlt/lp1205190_rebase

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1205190_rebase

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
milestone: none → 3.0-alpha
status: Incomplete → Confirmed
Mike Rylander (mrylander) wrote :

Well, after 4 long years, this CSS cleanup is finally in. Thanks Pasi, Dan, and Galen!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers