Fund tags are not carried over during fund propagation

Bug #1204671 reported by Kathy Lussier on 2013-07-24
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.7
Medium
Unassigned
2.8
Medium
Unassigned

Bug Description

Evergreen version: 2.3

During the Fiscal Year Close-out Operation, funds with propagation enabled are created, but any fund tags applied to the previous year's funds do not carry over to the newly-created funds. Our expectation is that fund tags would carry over with the propagated funds.

Ben Shum (bshum) wrote :

Presumably cloning the map entries for fund tag to funds would accomplish this.

Setting status to wishlist pending further discussion/review.

Changed in evergreen:
status: New → Triaged
Ben Shum (bshum) wrote :

err, not wishlist, but medium status. Since it probably should propagate this information...

Changed in evergreen:
importance: Undecided → Medium
Erica Rohlfs (erohlfs) on 2014-06-02
Changed in evergreen:
status: Triaged → Confirmed
Dan Pearl (dpearl) on 2015-01-06
Changed in evergreen:
assignee: nobody → Dan Pearl (dpearl)
Dan Pearl (dpearl) wrote :

This does the job. We have used this successfully at our installation.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dpearl/fund_tag_1204671

tags: added: pullrequest
Kathy Lussier (klussier) on 2015-07-15
Changed in evergreen:
assignee: Dan Pearl (dpearl) → nobody
Kathy Lussier (klussier) wrote :

Works for me. Sign-off branch at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1204671-fund-tag

Also, just adding a reminder about the new guideline to include test plans in the commit messages for bug fixes.

Thanks Dan!
Kathy

tags: added: signedoff
Changed in evergreen:
milestone: none → 2.9-alpha
Changed in evergreen:
milestone: 2.9-alpha → 2.9-beta
Ben Shum (bshum) wrote :

Pushed kathy's signoff branch to master with backports to rel_2_8 and rel_2_7.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers