"You have permission to override some of the failed holds." appearing when it should not for patrons in the OPAC

Bug #1194860 reported by Chris Sharp on 2013-06-26
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.7
Undecided
Unassigned
2.8
Undecided
Unassigned

Bug Description

This issue was brought up by Jim Keenan in bug 1099871 (which was marked as a duplicate of bug 1076062), but it was not actually addressed in the main bug. In Evergreen 2.3.6, when a patron places a hold on an age-protected item, the patron is presented with the message "You have permission to override some of the failed holds. Click Submit to override and place your hold on the selected items." Our patrons do not have the PLACE_UNFILLABLE_HOLD permission, so this message should not appear at all

Evergreen 2.3.6
OpenSRF 2.1.2
PostgreSQL 9.1.9
Ubuntu 12.04

Chris Sharp (chrissharp123) wrote :

I'll add some details about our use case in PINES since it sounds like the "place unfillable hold" feature was assumed to have general applicability for Evergreen-using libraries. PINES libraries range protect both newly-acquired items and audio-visual materials (DVDs, CDs, etc.) per library system so that A/V items do not transit for holds across library system lines, nor do new items for the first 6 months after creation/activation. These rules have been a source of frustration with our patrons for years, so when a message/option comes up in the OPAC that appears to allow patrons permission to place holds on those items, that creates a customer service problem for our libraries and causes the patron to believe they may be able to get around our policies.

It would be best for us if the message/option did not appear and that unfillable holds are not placed.

Rogan Hamby (rogan-hamby) wrote :

This sounds like the same issue I'm seeing with 2.4.1. Same cause, same behavior.

Kathy Lussier (klussier) wrote :

I'll reiterate what I said in the referenced IRC log. I think the best and possibly most straightforward solution is not to display a message here at all no matter what the permission level of the user.

- In cases where sites allow patrons to place unfillable holds, the message is confusing. I can't think of any case where a patron would choose NOT to override the block The message makes them think too much. I know there is already an option to suppress this message, but, since the message seems to be causing problems with other sites with different use cases, maybe we can decide at as a community that the message is just too confusing for patrons.

- In cases where sites do not allow patrons to place unfillable holds, then the patron should receive a message saying the hold failed.

Ben Shum (bshum) on 2014-02-16
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
tags: added: holds opac tpac
Blake GH (bmagic) wrote :

This code seems to have fixed the issue for us in a testing environment.
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=f03aed92d6ed4937765f87f9b07c66fe234a2998

tags: added: pullrequest
Liam Whalen (whalen-ld) wrote :

I have signed off on this branch.

The hold override message no longer appears for patrons.

Here is my signed off branch:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/ldw/LP1194860

Blake GH (bmagic) on 2015-06-05
Changed in evergreen:
assignee: nobody → Blake GH (blake-j)
Kathy Lussier (klussier) on 2015-06-08
tags: added: signedoff
Blake GH (bmagic) on 2015-06-08
Changed in evergreen:
assignee: Blake GH (blake-j) → nobody
Ben Shum (bshum) wrote :

Thanks Blake and Liam for testing. Pushed to master and backported to rel_2_8 and rel_2_7. Also, for conformity I edited the author field for blake to change it to "Blake Henderson" for completeness' sake.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers