Column picker preferences are not saved in the Circulation Policy Configuration interface

Bug #1193487 reported by Michele Morgan on 2013-06-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.3
Undecided
Unassigned
2.4
Undecided
Unassigned
2.5
Undecided
Unassigned

Bug Description

In the Circulation Policy Configuration client interface, right clicking on the column header row brings up the Column Picker, where you can hide fields and set sort priority. There is a Save button on the bottom of the screen, but the preferences don't appear to be saved anywhere. The next time you access the policy editor, the Column Picker preferences have reverted to the default. It would be extremely useful if this worked. It's working correctly in the simplified pull list interface.

Garry Collum (gcollum) wrote :

The user setting is not being created because ui.grid_columns.conify.config.circ_matrix_matchpoint
is not defined in the config.usr_setting_type table. This can be verified via the client
via Server Administration/User Setting Types and creating a new type with the following data and
then testing.

Name: ui.grid_columns.conify.config.circ_matrix_matchpoint
Label: Circulation Policy Configuration
Datatype: string
Description: Circulation Policy Configuration Column Settins
Opac Visable: False
Settings Group: gui

A branch to with the sql is at user/gcollum/lp1193487_circ_policy_column_picker

tags: added: pullrequest
Jason Stephenson (jstephenson) wrote :

I have rebased on master and signed off on the branch at working/collab/dyrcona/lp1193487_circ_policy_column_picker_signoff

I would have pushed this to master, but I hesitate because the bug is untargeted and I don't want to interfere with the beta churn.

I also think the release maintainers should evaluate this for backporting.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Changed in evergreen:
status: Confirmed → Fix Committed
Ben Shum (bshum) on 2013-12-06
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers