QP uses numeric cmp operator for comparing strings, fills logs with warnings

Bug #1192710 reported by Dan Scott on 2013-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

* Evergreen rel_2_4 as of 2013-06-19

Today's logs were filled with more than 7,000 instances of warnings like "open-ils.storage.biblio.multiclass.staged.search_fts: Argument "INNER" isn't numeric in numeric ne (!=) at /usr/local/share/perl/5.10.1/OpenILS/Application/Storage/Driver/Pg/QueryParser.pm line 949."

The problem is that a numeric comparison is being used where a string comparison operator should instead be used. Solved in:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/dbs/qp_silence_join_type_warning

Ben Shum (bshum) wrote :

Works for me. Thanks Dan! Picked to master and rel_2_4.

Changed in evergreen:
status: New → Fix Committed
Ben Shum (bshum) on 2013-07-23
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers