Acq Copy level not refreshing after marking a copy as received

Bug #1185495 reported by Mary Llewellyn on 2013-05-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

Evergreen 2.4 / master

When you go to the copy level of a purchase order, it used to be that if you clicked on "Mark Received", the screen would refresh and the entry would change to "Un-Receive." Since our upgrade to 2.4, it is no longer doing that. You get a quick scrolling box that shows the system has responded to the "Mark Receive" command, but the Mark Receive entry remains. You need to return to the full PO, then go back to the copy level to see that it's changed to "Un-Receive."

We would like the screen to refresh itself and see the entry change without having to leave the screen and return.

Mary Llewellyn (mllewell) wrote :
Erica Rohlfs (erohlfs) wrote :

I can confirm this behavior for Evergreen versions 2.4.4 and 2.5.0.

Two additional comments:

First, the same holds true as Mary describes if the user would like to view the “Receiver” data populate once the copy is marked received.

Second, the same holds true if a user selects “Un-Receive.” The gray scroll bar will appear, and the user must click “Return” and then go back into the copy information to see that the option updated to “Mark Received” and that the “Receiver” information deletes.

Changed in evergreen:
status: New → Confirmed
Jennifer Pringle (jpringle-u) wrote :

I can confirm this behaviour in EG 2.6.1 as well

This behavior for Evergreen version 2.11 is confirmed also.

Andrea Neiman (aneiman) on 2019-03-05
tags: added: purchaseorder
removed: 2.4 copy mark po received un-receive
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers