"Export All Records" does not work from "Manage Record Buckets"

Bug #1179614 reported by Anoop Atre on 2013-05-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.3
Medium
Unassigned
2.4
Medium
Unassigned

Bug Description

Evergreen versions: 2.3.6 & 2.4.0

Attempting an export of a record bucket "Export All Records" to any format from "Manage Record Buckets" doesn't work. There is no file saved and a prompt that it was exported or an error doesn't pop-up either. Neither were there any error logs that stood out or javascript errors on the client side.

Ben Shum (bshum) wrote :

Confirmed to not work for me either in 2.4/master. I have an angle on a fix though, branch forthcoming.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ben Shum (bshum)
Ben Shum (bshum) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Ben Shum (bshum) → nobody
Alan Simon (qp-simen-44) wrote :

I was the original reporter of this bug to Equinox. This patch corrects the issue with exporting records from a bucket on my Evergreen 2.3.6 test system.

Galen Charlton (gmc) wrote :

Ben's patch works for me as well, so I've pushed it to master, rel_2_4, and rel_2_3.

Thanks, Ben, for the patch!
Thanks, Alan, for testing!

Changed in evergreen:
status: Confirmed → Fix Committed
tags: removed: pullrequest
Jeff Godin (jgodin) on 2015-04-08
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers