Do not allow a list to be created with no name

Bug #1164720 reported by Kyle Tomita on 2013-04-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.5
Low
Unassigned

Bug Description

A patron has the ability to create a list without a name. This is not something that should be allowed. It is problematic because the patron cannot select the list because the name is used as the link.

Kyle Tomita (tomitakyle) on 2013-04-04
summary: - Not allow a list to be created with no name
+ Do not allow a list to be created with no name
Kyle Tomita (tomitakyle) wrote :

Here is the branch, http://git.evergreen-ils.org/?p=working/Evergreen.git;a=log;h=refs/heads/user/catalystit/lp1164720

I added the javascript function into the tt2 file. If you would like to see the Javascript function in a different file, please let me know.

tags: added: pullrequest
Changed in evergreen:
assignee: Kyle Tomita (tomitakyle) → nobody
Ben Shum (bshum) on 2013-04-14
Changed in evergreen:
importance: Undecided → Wishlist
status: New → Confirmed
Ben Shum (bshum) on 2013-04-22
Changed in evergreen:
milestone: 2.4.0-rc → 2.5.0-alpha
Pasi Kallinen (paxed) wrote :

Perhaps move the single quotes out of the translatable message string?

Kyle Tomita (tomitakyle) wrote :

Removed the single quotes from the translatable message string and updated to current Master.

The new branch is at:
http://git.evergreen-ils.org/?p=working/Evergreen.git;a=log;h=refs/heads/user/catalystit/lp1164720

Dan Wells (dbw2) on 2013-06-13
Changed in evergreen:
milestone: 2.5.0-m1 → 2.5.0-m2
Bill Erickson (berick) wrote :

I can see the value in a quick fix via JS, however I'll note that similar validation is performed without JS via the server-side form processing. See Account::load_myopac_update_email, load_myopac_update_username, and load_myopac_update_password. The loose guidelines for the TPAC and JS thus far have been to use JS only when there is no other way to accomplish the goal (and only for secondary features). Any chance this could be done with Perl/template changes instead for consistency?

Ben Shum (bshum) wrote :

Marking incomplete pending further review/discussion.

Changed in evergreen:
status: Confirmed → Incomplete
Dan Wells (dbw2) on 2013-07-15
Changed in evergreen:
milestone: 2.5.0-m2 → 2.5.0-alpha1
Remington Steed (rjs7) on 2013-08-12
Changed in evergreen:
milestone: 2.5.0-alpha1 → 2.5.0-alpha2
Dan Wells (dbw2) on 2013-08-26
Changed in evergreen:
milestone: 2.5.0-alpha2 → 2.5.0-beta1
Dan Wells (dbw2) on 2013-09-29
Changed in evergreen:
milestone: 2.5.0-beta1 → 2.5.0-rc
Dan Wells (dbw2) on 2013-10-16
Changed in evergreen:
milestone: 2.5.0-rc → 2.5.1
Ben Shum (bshum) on 2013-12-06
Changed in evergreen:
milestone: 2.5.1 → 2.5.2
Bill Erickson (berick) wrote :
Changed in evergreen:
status: Incomplete → Confirmed
milestone: 2.5.2 → 2.next
Ben Shum (bshum) on 2014-01-21
Changed in evergreen:
assignee: nobody → Ben Shum (bshum)
Dan Wells (dbw2) on 2014-02-05
Changed in evergreen:
milestone: 2.6.0-alpha1 → 2.6.0-beta1
Ben Shum (bshum) wrote :

Bill's server side approach works for me. I've signed off and pushed it to master first.

Question, should we backport this to previous releases as a "bug fix" since this probably shouldn't be allowed to occur in those systems either?

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Ben Shum (bshum) → nobody
Ben Shum (bshum) wrote :

Based on feedback from Mike (2.4) and Dan (2.5), this fix has now been backported to rel_2_4 and rel_2_5 respectively as a bug fix.

Changed in evergreen:
importance: Wishlist → Low
Changed in evergreen:
status: Fix Committed → Fix Released
no longer affects: evergreen/2.4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers