Error updating function in 2.0-2.1-upgrade-db.sql for 2.3

Bug #1125270 reported by StephenGWills on 2013-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
2.7
Undecided
Unassigned

Bug Description

While upgrading from 2.0 to 2.1 (on the way to 2.3) I ran into the following error in the 2.0-2.1-upgrade-db.sql script in the 2.3 dist.

-- 0480
CREATE OR REPLACE FUNCTION actor.usr_purge_data(

psql:2.0-2.1-upgrade-db.sql:636: ERROR: cannot change name of input parameter "dest_usr"
HINT: Use DROP FUNCTION first.

Adding DROP FUNCTION actor.usr_purge_data( INT, INT); solved the problem, a trick I discovered reading:
https://bugs.launchpad.net/evergreen/+bug/725809

Ben Shum (bshum) on 2013-03-03
Changed in evergreen:
importance: Undecided → Low
status: New → Triaged
Ben Shum (bshum) wrote :

Adding a DROP FUNCTION ahead of the CREATE OR REPLACE isn't too hard, but I'm not sure if this is still a major issue or how much we want to fix the 2.0 to 2.1 upgrade script this many major versions out of sync with the current supported Evergreen.

That said, it's an easy enough thing to drop in there...

Working branch: user/bshum/lp1125270-quick-fix

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/bshum/lp1125270-quick-fix

Changed in evergreen:
milestone: none → 2.8-beta
tags: added: pullrequest
Ben Shum (bshum) on 2015-04-02
Changed in evergreen:
milestone: 2.8-beta → 2.8.1
Galen Charlton (gmc) wrote :

Hopefully nobody is that far behind that this bug is still relevant, but just in case, I've pushed it to master, rel_2_8, and rel_2_7. Thanks, Ben!

no longer affects: evergreen/2.6
Changed in evergreen:
milestone: 2.8.1 → 2.8.2
status: Triaged → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers