tpac: no toggle to increase/decrease font size

Bug #1084758 reported by Kathy Lussier on 2012-11-29
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

From the list of JSPAC Features Missing from TPAC at http://evergreen-ils.org/dokuwiki/doku.php?id=dev:opac:template-toolkit:plan&#jspac_features_missing_from_tpac.

There is no toggle in tpac for users to easily increase/decrease the font size.

In opac mode, browsers usually will do this using Ctrl-+ and Ctrl--.
Ctrl-0 usually returns to the default size. I don't think we should
reimplement features already available in browsers.

For staff mode, I do believe this feature is missing, but will do some
checking to confirm later.

--
Jason Stephenson
Assistant Director for Technology Services
Merrimack Valley Library Consortium
Chief Bug Wrangler, Evergreen ILS

Ben Shum (bshum) wrote :

Suggesting more discussion on how to deal with this particular feature request.

tags: added: jspacremovalblocker
Changed in evergreen:
status: New → Opinion
importance: Undecided → Wishlist
milestone: none → 2.4.0-alpha
Ben Shum (bshum) on 2013-03-03
Changed in evergreen:
milestone: 2.4.0-alpha1 → 2.4.0-beta
Ben Shum (bshum) on 2013-03-17
Changed in evergreen:
milestone: 2.4.0-beta → 2.4.0-rc
Pasi Kallinen (paxed) wrote :

I agree with Jason - Browsers have the functionality to properly resize, so why should EG reimplement it? Also (at least some) browsers offer a setting to set the minimum font size used.

IF font size changing is added, we should test the OPAC for each font-size used, so everything still flows (relatively) well, and isn't hidden by overflow or something.

Kathy Lussier (klussier) wrote :

As Jason mentioned in his previous comment, the built-in browser functionality does not work in the staff client. Most of the complaints I've heard come from staff who are unable to increase the font size when they are using tpac in the staff client.

It doesn't necessarily need to be a toggle like the one that was available in jspac, but they do need some staff client setting to adjust the tpac font size.

<snip>
> functionality does not work in the staff client. Most of the complaints
> I've heard come from staff who are unable to increase the font size when
> they are using tpac in the staff client.

If we need more dynamic font control in the staff client, it may be
better to go into the XUL browser wrapper directly as new buttons in
the same area as the Forward/Back/Print buttons.

Thomas Berezansky (tsbere) wrote :

I rebased my "zoom" branch. It probably needs more work, but hey, it seems to work. Just needs less hardcoded values, I think.

Would be trivial, I expect, to add buttons to call the same commands.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/tsbere/zoom

Ben Shum (bshum) on 2013-04-22
Changed in evergreen:
milestone: 2.4.0-rc → 2.5.0-alpha
Kathy Lussier (klussier) wrote :

I know there isn't a pullrequest tag on this yet, but I asked Jason to load the code on his dev server after a discussion in IRC last month - http://evergreen-ils.org/irc_logs/evergreen/2013-04/%23evergreen.26-Fri-2013.log.

Overall, it worked very well for me and everything seems to flow well, even with very large font sizes. I would love to see this code in Evergreen because the smaller font size can present serious usability issue for staff. The one issue I found was that the change in font size is temporary. If you click the "Search Catalog" toolbar button or open a new tab, it reverts to the default font size.

Tom, do you know if there is a way to make the changed font size a bit stickier? If not, I would be inclined to support putting this code in as is so that staff have some method of adjusting tpac font size in the staff client. However, I could see staff becoming easily frustrated if they need to adjust the font size each time they go to the catalog search page.

Ben Shum (bshum) on 2013-05-22
Changed in evergreen:
status: Opinion → Confirmed
Dan Wells (dbw2) on 2013-06-12
Changed in evergreen:
milestone: 2.5.0-m1 → none
Bill Erickson (berick) wrote :

I've pushed a sign-off to Thomas' zoom commit, plus another commit to persist zoom preferences for the tpac (and possibly others) via user prefs.

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1084758-tpac-staff-zoom

tags: added: pullrequest
Changed in evergreen:
milestone: none → 2.5.0-beta1
Dan Wells (dbw2) on 2013-09-12
tags: added: 2.5-beta-blocker
Mike Rylander (mrylander) wrote :

Solid work, Thomas and Bill. In master now.

Changed in evergreen:
status: Confirmed → Fix Committed
Dan Wells (dbw2) on 2013-11-11
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers