Password changes not verified when editing user

Bug #1068656 reported by Jason Boyer on 2012-10-19
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Eg version 2.2.2
Other versions uncertain (inaccessible)

When creating a new user, the password and verify password options work as expected. If editing a user and assigning/resetting a password on demand, the verify password box is never checked, and they no longer need to match before saving.

Michael Peters (mrpeters) wrote :

Confirmed. For what it's worth, it takes the password from the "Password" field, and "Verify Password" is basically doing nothing.

Jason -- do you recall if this worked in earlier versions?

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium

I've not explicitly tested it before, but I believe so. I started looking into it because lately we're having a lot of people get their passwords set at a staff desk and they don't work immediately after.

Holly Brennan (hollyfromhomer) wrote :

This problem is fixed in 2.5.2. If the two fields don't match, you get a "Form is invalid. Please edit and try again." message. Yay!

Jason Boyer (jboyer) wrote :

Holly, did you try it when editing a patron, or when registering them? I just edited a patron on 2.5.2 and it appears to still be broken.

Holly Brennan (hollyfromhomer) wrote :

Yep, I was editing an account. If I put 1111 in the Password field and 2222 in Verify, it threw up the message. Just tried it again....

Just registered a fake account, and as soon as I start typing a different password in the Verify box, that small message points to the box and says the value is invalid. If I ignore that message and move onto the next field, the yellow explanation mark shows in the Verify field. It won't let me save the registration if they don't match.

So, for ME in 2.5.2, the Verify field is working properly for both editing existing patrons and registering new ones.

Weird. What else could be different between our systems that could cause different results? We upgraded to 2.5.2 last week on 2/19/14. We were on 2.3.4 previously, so we did 16 upgrades in between to get there, including the 2.3-2.4 supplemental.sh.

Holly Brennan (hollyfromhomer) wrote :

I brought this problem up when I discovered it the first week after our migration last year. The only thing I can think of is that Galen somehow patched our system during that time.. but the last email I have on record is from me confirming that it was happening in the staff client, not OPAC. But he's awesome like that, so he may have done something I just never noticed that it was fixed until this week.

Kathy Lussier (klussier) wrote :

I just tested this in master and had the same results as Jason. It worked for new patrons, but not when I was editing a patron.

Elaine Hardy (ehardy) on 2019-03-06
tags: added: patron
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers