tpac: genre links in record details page launch subject search

Bug #1067823 reported by Kathy Lussier on 2012-10-17
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Evergreen version: 2.2 and beyond

The record details page of a stock tpac installation include genre links below the subject links. A user's expectation is that clicking this link would lead to more materials of the same genre. Instead, it launches a subject search. The default subject class indexes do not index MARC tag 655 - nor should it.

In a database with properly-cataloged records, clicking on a genre link for "Graphic novels" will then lead to a search for materials about graphic novels instead of finding the actual graphic novels. Using the default indexes, there is no index you could link to for conducting a genre search.

Dan Scott (denials) wrote :

Hmm. My expectation as a user, based on how the rest of the record is laid out and the behaviour of links, would be that clicking on the Genre link would launch a brand new search for records that have a matching Genre tag. So clicking on Genre: "Graphic Novels" would find all graphic novels.

If I'm correct, it sounds like you expect this to act more like a Facet - and thus should narrow the existing search results to that particular genre?

Kathy Lussier (klussier) wrote :

No, my expectation is the same as yours. It should launch a brand new search matching the genre tag. But the current behavior is to launch a subject search, not a genre search.

Ben Shum (bshum) on 2012-12-13
Changed in evergreen:
status: New → Triaged
importance: Undecided → Medium
Ben Shum (bshum) wrote :

Meant to mark as confirmed.

Changed in evergreen:
status: Triaged → Confirmed
Jeff Godin (jgodin) on 2013-05-10
Changed in evergreen:
assignee: nobody → Jeff Godin (jgodin)
Mike Rylander (mrylander) wrote :

To provide some history, genre was originally in the subject class. It was removed as an index def entirely at some point. Thus the search link.

Based on the actual use and real world data of the field, I recommend an index def in the identifier class marked for both search and facet use. That will cause no practical conflict with other searches (subject or identifier), and genre really is something of a classifier, if not a unique identifier.

BTW, one can "search" using only a facet, and you gain the benefit of exact matching, which seems important for genre. IOW, a facet probably is best.

Mike Rylander (mrylander) wrote :
tags: added: pullrequest
Changed in evergreen:
assignee: Jeff Godin (jgodin) → nobody
Galen Charlton (gmc) on 2015-10-29
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Galen Charlton (gmc) wrote :

I've tested and written a couple follow-ups (including release notes, as a partial reingest is required to make use of this). A four-patch series can be found at the tip of the user/gmcharlt/lp1067823_genre_index branch in the working/Evergreen repository:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/gmcharlt/lp1067823_genre_index

This is now ready for independent testing.

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
Andrea Neiman (aneiman) on 2015-12-09
Changed in evergreen:
assignee: nobody → Andrea Neiman (aneiman)
Andrea Neiman (aneiman) wrote :

I have tested this code and consent to signing off on it with my name Andrea Neiman and email address <email address hidden>

Changed in evergreen:
assignee: Andrea Neiman (aneiman) → nobody
tags: added: signedoff
Kathy Lussier (klussier) on 2016-02-03
Changed in evergreen:
assignee: nobody → Kathy Lussier (klussier)
Kathy Lussier (klussier) wrote :

This looks good. I agree with Mike that genre will work best as a facet. As such, I was thinking of adding a commit that adds the genre facet to config.tt2 so that it displays by default.

Would people be okay with genre being included as part of the default facet display or do you prefer letting Evergreen sites configure it on their own (if they know how)?

Galen Charlton (gmc) wrote :

+1 to having it be included by default.

Kathy Lussier (klussier) wrote :

Added Andrea's and my signoffs to the branch and added a commit that:

* Displays the genre facet by default
* Removes the 659 tag from the index definition and from the display of genre links on the record summary page. The 659 had previously been included in those genre links, but is an unassigned MARC field.
* Updates the release notes to reflect those changes.

Branch is in the working repo at http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/kmlussier/lp1067823_genre_index

Changed in evergreen:
assignee: Kathy Lussier (klussier) → nobody
milestone: none → 2.10-beta

+1 ton it as well, I agree that from a searching workflow standpoint it would work best that way

---Sent from iPhone

+1 to having it be included by default.

--
You received this bug notification because you are subscribed to

Evergreen.

Matching subscriptions: evergreenbugs

https://bugs.launchpad.net/bugs/1067823

Title:

  tpac: genre links in record details page launch subject search

Status in Evergreen:

  Confirmed

Bug description:

  Evergreen version: 2.2 and beyond

  The record details page of a stock tpac installation include genre

  links below the subject links. A user's expectation is that clicking

  this link would lead to more materials of the same genre. Instead, it

  launches a subject search. The default subject class indexes do not

  index MARC tag 655 - nor should it.

  In a database with properly-cataloged records, clicking on a genre

  link for "Graphic novels" will then lead to a search for materials

  about graphic novels instead of finding the actual graphic novels.

  Using the default indexes, there is no index you could link to for

  conducting a genre search.

To manage notifications about this bug go to:

https://bugs.launchpad.net/evergreen/+bug/1067823/+subscriptions

Galen Charlton (gmc) wrote :

Now pushed to master. Thanks, Mike, Andrea, and Kathy!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers