Patron editor field documentation doesn't display text

Bug #1038240 reported by Bill Erickson on 2012-08-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.3
Medium
Unassigned
2.4
Medium
Unassigned
2.5
Medium
Unassigned

Bug Description

Evergreen 2.3 and possibly earlier.

When applying field-level documentation (admin -> local admin -> field documentation) to fields visible in the patron editor UI, a magnifying glass appears along the left of the field in the interface. Clicking on this icon opens a box along the right of the page which should contain the name of the field and the contents of the field documentation for that field. In Evergreen 2.3 (and possibly earlier) the box displays with the label but it is otherwise empty.

The box also needs a top margin to prevent it from overlapping with the action buttons / links box.

Ben Shum (bshum) wrote :

Confirmed, we saw this too.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 2.3.2
Ben Shum (bshum) on 2012-12-21
Changed in evergreen:
milestone: 2.3.2 → 2.3.3
Changed in evergreen:
milestone: 2.3.3 → 2.4.0-alpha
Ben Shum (bshum) on 2013-03-03
Changed in evergreen:
milestone: 2.4.0-alpha1 → 2.4.0-beta
Ben Shum (bshum) on 2013-03-17
Changed in evergreen:
milestone: 2.4.0-beta → 2.4.0-rc
Ben Shum (bshum) on 2013-04-27
Changed in evergreen:
milestone: 2.4.0-rc → none
Kyle Tomita (tomitakyle) wrote :

I have a solution for this but lost my ssh key, so I cannot submit the branch. I am just waiting for it to be added, in the mean time, here is the commit in case someone would be so kind as submitting it for me. Unless I will commit it once I can, thanks.

commit 0b5b4361b860bd21ad3bdf06ec68171ca405e05c
Author: Kyle Tomita <email address hidden>
Date: Tue Sep 24 09:55:02 2013 -0700

    LP1038240 - Patron editor field documentation does not display text

    Changed the legend tag to have a closing tag.
    Also modified the css id uedit-help-div, to add a top margin so
    it does not overlap the save div.

    Signed-off-by: Kyle Tomita <email address hidden>

diff --git a/Open-ILS/src/templates/actor/user/register.tt2 b/Open-ILS/src/templates/actor/user/register.tt2
index 95be962..2f76450 100644
--- a/Open-ILS/src/templates/actor/user/register.tt2
+++ b/Open-ILS/src/templates/actor/user/register.tt2
@@ -33,7 +33,7 @@
 <!-- context help widget -->
 <a class='hidden' id='uedit-help-template'><img src='/opac/images/advancedsearch-icon.png'></img></a>
 <fieldset id='uedit-help-div' class='hidden'>
- <legend id='uedit-help-field'/>
+ <legend id='uedit-help-field'></legend>
     <div id='uedit-help-text'></div>
 </fieldset>

diff --git a/Open-ILS/web/css/skin/default/register.css b/Open-ILS/web/css/skin/default/register.css
index 3ea7309..8b5736b 100644
--- a/Open-ILS/web/css/skin/default/register.css
+++ b/Open-ILS/web/css/skin/default/register.css
@@ -30,6 +30,7 @@
     -moz-border-radius: 10px;
     font-weight: bold;
     padding: 20px;
+ margin-top: 20px;
 }

 #uedit-dupe-div {

Changed in evergreen:
assignee: nobody → Kyle Tomita (tomitakyle)
Kyle Tomita (tomitakyle) wrote :

Here is the branch in the working repo, user/ktomita/lp1038240-patron_editor_field_help_text

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=refs/heads/user/ktomita/lp1038240-patron_editor_field_help_text

tags: added: pullrequest
Changed in evergreen:
assignee: Kyle Tomita (tomitakyle) → nobody
Bill Erickson (berick) wrote :

Looks good. Help text is now appearing. Thanks, Kyle.

Merged to 2.4+

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 2.next
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers