tpac: record subject links carry previous search terms after MARC expert search

Bug #1037171 reported by Kathy Lussier on 2012-08-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
2.3
Medium
Unassigned
2.4
Medium
Unassigned

Bug Description

Evergreen versions: 2.2

After performing a MARC expert search, if you click on one of the subject links in a resulting record, the MARC expert search terms are carried over into the new subject search. This differs from the behavior after other searches, where the previous search terms are dropped and an entirely new subject search is performed.

I'm guessing this is because an expert search does not include the "query=" parameters that normally would be replaced by the search terms from the subject search.

Ben Shum (bshum) wrote :

Confirmed for me on 2.3+ as well.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Changed in evergreen:
milestone: none → 2.4.0-alpha
Ben Shum (bshum) on 2013-03-03
Changed in evergreen:
milestone: 2.4.0-alpha1 → 2.4.0-beta
Ben Shum (bshum) on 2013-03-17
Changed in evergreen:
milestone: 2.4.0-beta → 2.4.0-rc
Ben Shum (bshum) on 2013-04-27
Changed in evergreen:
milestone: 2.4.0-rc → none
Ben Shum (bshum) on 2013-08-22
no longer affects: evergreen/2.2
tags: added: expertsearch opac
Liam Whalen (whalen-ld) wrote :

I need to add the sort variable to the list of variables that get removed from the Subject and Author links. Otherwise, the sort from the previous search will be applied to the Subject and Author searches. I have removed the pullrequest for now. Sorry about that. I am testing this currently, and should have the modification up by the end of today.

tags: removed: pullrequest
Jason Stephenson (jstephenson) wrote :

I was going to take a look at this branch for Kathy Lussier. However, it needs rebasing with master as there are conflicts in way too many files. I imagine that many of these are whitespace changes, but I don't feel up to the task of resolving them all.

Liam Whalen (whalen-ld) wrote :

I am finally caught up here. I will setup a testing environment this weekend and try to resolve the confilicts.

There is an error with this commit as well. I have fixed it in the version I am using for Sitka, so I will modify my working branch to take into account that fix.

Liam Whalen (whalen-ld) wrote :

I have two commits for this LP bug on my working branch:

EG 2.4

Tested on EG 2.4.2
Ubuntu 12.04
OpenSRF 2.2.0
Postgres 9.1

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=e9ced5083245c2a7fa7430a4a7753974b63bb688

EG 2.5

Tested on EG 2.5 master
Ubuntu 12.04
OpenSRF 2.2.0
Postgres 9.1

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=330ebfe4729924f7741eafa7efe551f99aaa4fdf

I have not put one together yet for 2.3.10. The code around this has changed a bit since 2.3, and I do not have the time tonight to figure out the differences.

Liam

Liam Whalen (whalen-ld) wrote :

I decided to give 2.3 another look. I was hesitant to change it tonight because the series.tt2 file did not use mkurl, which is how this fix is created.

However, on a closer look, series.tt2 is not affected by this bug until 2.4, so I did not have to touch it for 2.3. The rest of the files were fairly similar to 2.4 and 2.5, so it was an even easier fix than the other two because there is one less file to worry about.

In this process, I noticed that I did not mention series links in my commit message for either 2.4 or 2.5, so I made some minor edits there and repushed them to my working branches.

So, here is everything once more:

EG 2.3
Tested on EG 2.3.10
Ubuntu 12.04
OpenSRF 2.1.2
Postgres 9.1

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=ae0d31f2ead8374c272966061f612ce480628339

EG 2.4

Tested on EG 2.4.2
Ubuntu 12.04
OpenSRF 2.2.0
Postgres 9.1

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=aa7ea10899603bca6bcc458f8fdc61d2aa5a18a2

EG 2.5

Tested on EG 2.5 master
Ubuntu 12.04
OpenSRF 2.2.0
Postgres 9.1

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=c370a6e48343c4fda925bd8abc7af3e277fd978d

Liam

tags: added: pullrequest

Hi Liam,

This looks really good. I have one nit.

By clearing all of stop_parms from the advanced search link, if you do an advanced search, look at the results, then click the advanced search link with an aim of refining your search terms further, you now find that all those terms are cleared, which may not be desirable.

If you agree, I think in the last hunk of your patches you just want the last parameter to mkurl to be expert_search_parms rather than general_search_parms.merge(expert_search_parms).

Thanks!

Liam Whalen (whalen-ld) wrote :

Hi Lebbeous,

Thank you for looking over the commits. I do not have access to 2.3 right now. But, on my 2.4 system, when I do an advanced search, there is a Refine My Original Search link, underneath the Advanced Search link. This commit does not affect that link. I do not know what the expected use for the Advanced Search link is, but I assume, with the presence of a refine link, that it would start a new search.

If my assumption is incorrect, I will happily remove the clearing of the params from the Adavanced link. There is also an Advanced a Search button. Should that retain the parameters as well?

Liam

Mike Rylander (mrylander) wrote :

For 2.4+ I think Liam has the right of it. I'm picking into those now, but I'll leave 2.3 alone.

Changed in evergreen:
assignee: nobody → Mike Rylander (mrylander)
status: Confirmed → Fix Committed
assignee: Mike Rylander (mrylander) → nobody
Kathy Lussier (klussier) on 2014-05-28
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers