Display Issues with Some Acquisitions Admin Interfaces

Bug #1032171 reported by Tim Spindler on 2012-08-02
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Version 2.2.0

When a library has permissions to only see their EDI accounts, there are blank lines and pages (essentially hiding accounts for other libraries).

I captured a screen cast here.

http://screencast.com/t/EzcFTM0bYu

Tim Spindler (tspindler-cwmars) wrote :

I removed the above link and re did the screen cast here.

http://screencast.com/t/c3jyIsabogp

Changed in evergreen:
status: New → Triaged
Christine Morgan (cmorgan-z) wrote :

Still occurring in 2.3.7. The above links don't seem to be working any longer so here is a new one.

http://screencast.com/t/dGOu7PpAAT

Kathy Lussier (klussier) wrote :

Just a note that this bug appears to be similar to https://bugs.launchpad.net/evergreen/+bug/731510 where the same thing was happening on the acquisitions providers screen. That bug was resolved by adding the ou selector to the screen. Perhaps a similar fix would work for this bug.

Pasi Kallinen (paxed) wrote :

This seems to be a dojo bug - I've traced it down to dojox.grid.DataGrid._resize()

Around line 13390:

   }else if(this.fitTo == "parent"){
           var h = dojo._getContentBox(pn).h;
                            dojo.marginBox(this.domNode, { h: Math.max(0, h) });
   }

The value of h just keeps increasing...

Kathy Lussier (klussier) wrote :

Adding a link to a screencast showing the same issue in the Acq -> Funding Sources interface. The only thing that is a little different is that we get the spinning wheel on the first page. The two accounts that the logged-in user is allowed to access appear on page 2 and page 3. When I then log in as a user who has permission to see everything. those two accounts are listed on the same page.

http://www.screencast.com/t/ionSKatb

I'm still trying to verify whether the problem in the Funding Sources interface is new to 2.4 or if it was also a problem in 2.3.

This bug makes it very difficult for staff to find the EDI Accounts or Funding Sources that they need to access or for them to even know that they are already there.

tags: added: acq
summary: - EDI Accounts Display
+ Display Issues with Some Acquisitions Admin Interfaces
Kathy Lussier (klussier) on 2014-08-12
Changed in evergreen:
status: Triaged → Confirmed
importance: Undecided → Medium
Tiffany Little (tslittle) wrote :

Since the transition for some of the Acquisitions Administration screens to Angular, I have not seen this behavior in EDI Accounts. The screen also now has an ou selector as Kathy mentioned above. Marking Won't Fix.

Changed in evergreen:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers