Compilation error with new Scratch APIs

Bug #922658 reported by Mario Guerriero
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Euclide
Medium
Unassigned
Scratch
Fix Released
Undecided
Unassigned

Bug Description

Since the Scratch APIs were updated and Euclide was ported to them, it doesn't compile with this error:

scratchplugins.vapi:6.3-6.38: error: `Scratch.Plugins' already contains a definition for `Interface'
  public class Interface : GLib.Object {
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
scratchcore.vapi:38.3-38.38: note: previous definition of `Interface' was here
  public class Interface : GLib.Object {
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
scratchplugins.vapi:32.3-32.36: error: `Scratch.Plugins' already contains a definition for `Manager'
  public class Manager : GLib.Object {
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
scratchcore.vapi:65.3-65.36: note: previous definition of `Manager' was here
  public class Manager : GLib.Object {
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation failed: 2 error(s), 0 warning(s)

I am not sure if the problem is in the vapis generation from the editor or if the problem is of the plugin.

Revision history for this message
xapantu (xapantu) wrote : Re: [Bug 922658] [NEW] Compilation error with new Scratch APIs

 status invalid

It is a problem on your computer, just delete all scratchplugins.vapi file
(in both /usr/local/share/vala/vapi and /usr/share/vala/vapi if needed).

2012/1/27 Mario Guerriero <email address hidden>

> Public bug reported:
>
> Since the Scratch APIs were updated and Euclide was ported to them, it
> doesn't compile with this error:
>
> scratchplugins.vapi:6.3-6.38: error: `Scratch.Plugins' already contains a
> definition for `Interface'
> public class Interface : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> scratchcore.vapi:38.3-38.38: note: previous definition of `Interface' was
> here
> public class Interface : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> scratchplugins.vapi:32.3-32.36: error: `Scratch.Plugins' already contains
> a definition for `Manager'
> public class Manager : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> scratchcore.vapi:65.3-65.36: note: previous definition of `Manager' was
> here
> public class Manager : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> Compilation failed: 2 error(s), 0 warning(s)
>
>
> I am not sure if the problem is in the vapis generation from the editor or
> if the problem is of the plugin.
>
> ** Affects: euclide
> Importance: Undecided
> Status: New
>
> ** Affects: scratch
> Importance: Undecided
> Status: New
>
> ** Also affects: scratch
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of Euclide
> Developers, which is the registrant for Euclide.
> https://bugs.launchpad.net/bugs/922658
>
> Title:
> Compilation error with new Scratch APIs
>
> Status in Euclide:
> New
> Status in Scratch:
> New
>
> Bug description:
> Since the Scratch APIs were updated and Euclide was ported to them, it
> doesn't compile with this error:
>
> scratchplugins.vapi:6.3-6.38: error: `Scratch.Plugins' already contains a
> definition for `Interface'
> public class Interface : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> scratchcore.vapi:38.3-38.38: note: previous definition of `Interface' was
> here
> public class Interface : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> scratchplugins.vapi:32.3-32.36: error: `Scratch.Plugins' already contains
> a definition for `Manager'
> public class Manager : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> scratchcore.vapi:65.3-65.36: note: previous definition of `Manager' was
> here
> public class Manager : GLib.Object {
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> Compilation failed: 2 error(s), 0 warning(s)
>
>
> I am not sure if the problem is in the vapis generation from the editor
> or if the problem is of the plugin.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/euclide/+bug/922658/+subscriptions
>

Changed in euclide:
status: New → Invalid
Revision history for this message
xapantu (xapantu) wrote :

Oh, actually it is a problem of euclide, sorry...

Changed in scratch:
status: New → Invalid
Changed in euclide:
status: Invalid → Confirmed
Changed in scratch:
status: Invalid → Confirmed
xapantu (xapantu)
Changed in euclide:
status: Confirmed → Fix Committed
Changed in scratch:
status: Confirmed → Fix Committed
Daniel Fore (danrabbit)
Changed in scratch:
status: Fix Committed → Fix Released
milestone: none → 1.1
Changed in euclide:
milestone: none → 0.1
status: Fix Committed → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers