Opening a file results in a very narrow editing pane

Bug #821956 reported by Pim Vullers
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Euclide
Medium
Unassigned

Bug Description

The editor only uses a small portion of the window, beside it there is a lot of empty space (see screenshot).

Console output:
pim@chaos ~ $ euclide
** (euclide:11100): DEBUG: Plugins.vala:32: Plugin dir: /usr/local/share/euclide//plugins

(euclide:11100): Gtk-CRITICAL **: gtk_file_chooser_set_current_folder: assertion `filename != NULL' failed

(euclide:11100): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkPathBar's child GtkButton 0x2359480. Allocation is 25x37, but minimum required size is 31x25.

(euclide:11100): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkButton's child GtkArrow 0x245c930. Allocation is 9x27, but minimum required size is 15x15.

(euclide:11100): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkPathBar's child GtkButton 0x2359480. Allocation is 25x37, but minimum required size is 31x25.

(euclide:11100): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkPathBar's child GtkButton 0x2359480. Allocation is 25x37, but minimum required size is 31x25.

(euclide:11100): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkPathBar's child GtkButton 0x2359480. Allocation is 25x37, but minimum required size is 31x25.

(euclide:11100): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkPathBar's child GtkButton 0x2359480. Allocation is 25x37, but minimum required size is 31x25.

(euclide:11100): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkPathBar's child GtkButton 0x2359480. Allocation is 25x37, but minimum required size is 31x25.

(euclide:11100): GLib-GObject-WARNING **: invalid cast from `GtkBox' to `GtkVBox'

(euclide:11100): GLib-GObject-CRITICAL **: g_object_ref_sink: assertion `G_IS_OBJECT (object)' failed

(euclide:11100): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
pim@chaos ~ $

The gtk_widget_size_allocate() warnings are displayed when switching directories in the open dialog.
The 'invalid cast from `GtkBox' to `GtkVBox'' might be the cause of this problem.

Revision history for this message
Pim Vullers (pimvullers) wrote :
xapantu (xapantu)
Changed in euclide:
status: New → Fix Committed
Changed in euclide:
status: Fix Committed → Fix Released
importance: Undecided → Medium
milestone: none → 0.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers