euclide fails to start (/usr/bin/euclide is out-of-date)

Bug #1017059 reported by Pim Vullers
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Euclide
Low
Mario Guerriero
Scratch
Invalid
Undecided
Unassigned

Bug Description

When I try to open euclide from slingshot it just opens scratch, without plugins. When I start it from a terminal it opens scratch with 4 files: -s, -n, -a and euclide. i.e. scratch fails to interpret the command/cannot find the plugins.

Revision history for this message
Nick Melnick (nmelnick) wrote :

Adding confirmation with additional information. Built scratch and euclide from trunk on 2012-06-23 on Ubuntu 12.04 64-bit, vala 0.16.

Revision history for this message
Pim Vullers (pimvullers) wrote :

Same for me, built scratch and euclide from trunk on 2012-06-23 on Gentoo (hardened) 64-bit, vala 0.16.

Revision history for this message
Mario Guerriero (mefrio-g) wrote :

Does it happen anymore?

Revision history for this message
Pim Vullers (pimvullers) wrote :

It still happens, had to modify euclide script, since that was looking for scratch instead of scratch-text-editor.

Revision history for this message
Nick Melnick (nmelnick) wrote :

Yep, still happens. The "-a" is what throws it all off, with or without the argument expansion. Removing that causes euclide to start properly.

Revision history for this message
Mario Guerriero (mefrio-g) wrote :

euclide launcher seems to be ok. Can't confirm this bug

Changed in scratch:
status: New → Invalid
Changed in euclide:
status: New → Invalid
Revision history for this message
Nick Melnick (nmelnick) wrote :

That's awesome.

Revision history for this message
Pim Vullers (pimvullers) wrote :

Just build scratch and euclide from trunk. This gives me the following euclide script:

chaos ~ # cat /usr/bin/euclide
#!/usr/bin/env bash

scratch -s euclide -n -a $@
chaos ~ #

The desktop file contains:
...
Exec=scratch-text-editor --set euclide
...

So to me it seems the 'executable' did not get updated.

Changed in euclide:
status: Invalid → New
summary: - euclide fails to start (plugins not recognised by scratch?)
+ euclide fails to start (/usr/bin/euclide is out-of-date)
Revision history for this message
Cody Garver (codygarver) wrote :

Happens to me.

Revision history for this message
Pim Vullers (pimvullers) wrote :

The attached patch solves this bug and updates the /usr/bin/euclide script to use scratch-text-editor instead of scratch.

Changed in euclide:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Mario Guerriero (mefrio-g)
Changed in euclide:
milestone: none → 0.1
Changed in euclide:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers