euca_conf --register-cluster is not idempotent

Bug #628328 reported by Dmitrii Zagorodnov on 2010-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Medium
chris grzegorczyk
eucalyptus (Ubuntu)
Undecided
Dave Walker

Bug Description

Trying to register an already existing cluster results in an error and in cluster keys on the CLC being overwritten. Example from an all-in-one setup:

# md5sum var/lib/eucalyptus/keys/cluster-cert.pem var/lib/eucalyptus/keys/KLUSTER/cluster-cert.pem
a63c195df18aedc2a16c45618c33a44d var/lib/eucalyptus/keys/cluster-cert.pem
494a5b8383ebea76660a9e0d089444f0 var/lib/eucalyptus/keys/KLUSTER/cluster-cert.pem

# usr/sbin/euca_conf --register-cluster KLUSTER 192.168.7.7
ERROR: failed to register new cluster, please log in to the admin interface and check cloud status.

# md5sum var/lib/eucalyptus/keys/cluster-cert.pem var/lib/eucalyptus/keys/KLUSTER/cluster-cert.pem
a63c195df18aedc2a16c45618c33a44d var/lib/eucalyptus/keys/cluster-cert.pem
a316978f44017821c8e339e5533d8b08 var/lib/eucalyptus/keys/KLUSTER/cluster-cert.pem

After this the cluster is still visible in the Web UI. The relevant entries from cloud-error.log are attached.

Neil Soman (neilsoman) wrote :

Fixed in revno 1236.

Changed in eucalyptus:
status: New → Fix Committed
Neil Soman (neilsoman) wrote :

Sorry, it is 1237, not 1236.

Dave Walker (davewalker) on 2010-09-10
Changed in eucalyptus (Ubuntu):
status: New → Confirmed
assignee: nobody → Dave Walker (davewalker)
Colin Watson (cjwatson) wrote :

eucalyptus (2.0+bzr1239-0ubuntu1) maverick; urgency=low

  [Dave Walker (Daviey)]
  * New upstream stable release, -r1239 Fixes:
    - euca_conf --register-cluster is not idempotent. (LP: #628328)
    - unexpected errors after a sequence of tests (LP: #622818)
  * debian/control:
    - Recommend bittorrent|bittornado for -walrus package, enabling S3
      bittorent API support. (LP: #613535)
    - Raise the minimum version of libvirt-bin needed to eucalyptus-nc.
  * debian/eucalyptus-nc.postinst: Add eucalyptus user to the kvm group to
    enable user to utilise console logs. (LP: #619843)
  * debian/patches/18-priv_security.patch: Added vgscan to util/wrappers.conf,
    as it requires escalated privileges. (LP: #628291)
  * debian/patches/06-UEC-webinterface.patch (and 3 images): Updated and
    refreshed to better reflect Ubuntu branding. (LP: #631451)
  * debian/patches/25-uec-logo-png.patch: Due to a bug in dpkg, we need to use
    a different filename for the logo.png.
  * debian/eucalyptus-{java-,}common.{preinst,postinst}: Update the internal
    database and keys on upgrade from 10.04.

  [Scott Moser]
  * fix determination of 'is_multiboot'.

 -- Dave Walker (Daviey) <email address hidden> Fri, 10 Sep 2010 12:18:02 +0100

Changed in eucalyptus (Ubuntu):
status: Confirmed → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers