Can't create volume from snapshot with different size

Bug #611769 reported by Bradley Hook on 2010-07-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
Neil Soman
eucalyptus (Ubuntu)
Undecided
Unassigned

Bug Description

I am using Ubuntu 10.04 Server installed as Ubuntu Enterprise Cloud. All software has been fully updated to the Ubuntu repositories as of July 30, 2010. I am using Hybridfox for my interface. The cloud has been reconfigured to allow up to 50GB volumes, which work fine if directly created.

I have created a 2GB snapshot that has template data on it, and I want to create a 25GB volume from this snapshot to actually use with an instance. I can put in the desired information, and everything shows fine until the volume is finished being created, at which point the interface changes to show it as only 2GB.

As a work-around I am creating a separate volume from scratch, then attaching and mounting both volumes and using rsync to copy everything over. This is far from ideal.

Because eucalyptus allows the user to request a change in volume size, this appears to be a bug.

Neil Soman (neilsoman) on 2010-08-06
Changed in eucalyptus:
status: New → Confirmed
assignee: nobody → Neil Soman (neilsoman)
Neil Soman (neilsoman) wrote :

------------------------------------------------------------
revno: 1227 [merge]
fixes bug(s): https://launchpad.net/bugs/611769
committer: Neil
branch nick: devel
timestamp: Thu 2010-08-12 18:11:39 -0700
message:
  fixes LP: #611769
------------------------------------------------------------

Changed in eucalyptus:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 2.0~bzr1230-0ubuntu1

---------------
eucalyptus (2.0~bzr1230-0ubuntu1) maverick; urgency=low

  * New upstream merge, r1230 - bug fixes:
    - (LP: #617127, #611769, #617032, #613033, #613033, #584497)
  * debian/patches/18-priv_security.patch: Added *_iscsitarget.pl scripts to
    the wrappers.conf whitelist. (LP: #615646)
  * debian/patches/15-fix-default-ramdisk.patch: Dropped, fixed applied upstream.
 -- Dave Walker (Daviey) <email address hidden> Fri, 13 Aug 2010 11:25:25 +0100

Changed in eucalyptus (Ubuntu):
status: New → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers