potential db connection leak when no default kernel/ramdisk id is not set

Bug #534877 reported by chris grzegorczyk on 2010-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
chris grzegorczyk
eucalyptus (Ubuntu)
High
Dustin Kirkland 

Bug Description

When no kernel or ramdisk is listed as the default, by being set in the web interface, each attempt to load the system configuration may leak database connections. The is manifested in the log files as a message to the effect of "remove connection because it has problems: age is XXXXX ms. connection marked for expiry but the last SQL it performed is unknown because the trace property is not enabled."

One way to trigger this is to run multiple clients (16+) at the same time which will result:

16:49:22 [TxHandle:New I/O server worker #1-3] ERROR javax.persistence.PersistenceException: org.hibernate.exception.GenericJDBCException: Cannot open connection
...
Caused by: java.sql.SQLException: We are already in the process of making 17 connections and the number of simultaneous builds has been throttled to 16

summary: - potential db connection leak when no default kernel/ramdisk id is set
+ potential db connection leak when no default kernel/ramdisk id is not
+ set
chris grzegorczyk (chris-grze) wrote :

------------------------------------------------------------
revno: 1209 [merge]
committer: decker <decker@hawaii>
branch nick: 1.6.2
timestamp: Mon 2010-03-08 23:01:52 -0800
message:
  fix LP: #534877 prevent corner case db conn. leak
------------------------------------------------------------

Changed in eucalyptus:
assignee: nobody → chris grzegorczyk (chris-grze)
status: New → In Progress
status: In Progress → Fix Committed
Changed in eucalyptus (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2-0ubuntu26

---------------
eucalyptus (1.6.2-0ubuntu26) lucid; urgency=low

  * Cherry-pick merge from upstream 1.6.2, now on revision 1217
    - LP: #534877 - fix potential db connection leak when no
      default kernel/ramdisk set
    - LP: #534868 - update expiration deadline
    - LP: #534869 - correct misleading error message
    - LP: #437026 - fix auth failures due to timezone
    - LP: #535335 - fix display of failed volumes
    - LP: #537058 - fix creation of large numbers of volumes
    - LP: #538604 - remember storage stats across sc restarts
    - LP: #547059 - fix euca-describe-snapshots
    - LP: #544992 - fix get-all-keys
 -- Dustin Kirkland <email address hidden> Mon, 29 Mar 2010 12:48:13 -0500

Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers