euca-get-console-output repeats output on subsequent runs

Bug #531536 reported by Scott Moser on 2010-03-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
chris grzegorczyk
euca2ools (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
eucalyptus (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

euca-get-console-output seems to repeat itself once for every time it is run, and get slower also.
For example:

$ id=i-42DC08AD;
$ euca-describe-images emi-A89717DA
IMAGE emi-A89717DA lucid-server-20100224/lucid-server-uec-amd64.img.manifest.xml admin available public x86_64 machine eki-0F4A1CE9

$ euca-describe-instances $id
RESERVATION r-3BB80760 admin default
INSTANCE i-4B5808C7 emi-A89717DA 10.1.1.100 172.19.1.2 running mykey 0 c1.medium 2010-03-03T18:52:41.391Z cluster1 eki-0F4A1CE9

$ TIMEFORMAT=$'\nreal: %3lR' ;
$ while : ; do time euca-get-console-output $id > out && ls -l out && sleep 5 || break; done
real: 0m0.239s
-rw-r--r-- 1 ubuntu ubuntu 19264 2010-03-03 13:03 out
real: 0m0.253s
-rw-r--r-- 1 ubuntu ubuntu 38491 2010-03-03 13:03 out
real: 0m5.792s
-rw-r--r-- 1 ubuntu ubuntu 57718 2010-03-03 13:03 out
real: 0m11.270s
-rw-r--r-- 1 ubuntu ubuntu 76945 2010-03-03 13:03 out
real: 0m15.446s
-rw-r--r-- 1 ubuntu ubuntu 96172 2010-03-03 13:04 out
real: 0m19.492s
-rw-r--r-- 1 ubuntu ubuntu 115399 2010-03-03 13:04 out

If you look at 'out', it is just the repeated boot sequence... the instance isn't actually writing anything new.

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 3 12:45:15 2010
DistroRelease: Ubuntu 10.04
Package: eucalyptus-cloud 1.6.2-0ubuntu7
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-server
SourcePackage: eucalyptus
Uname: Linux 2.6.32-15-server x86_64

Scott Moser (smoser) wrote :
Scott Moser (smoser) on 2010-03-03
Changed in eucalyptus (Ubuntu):
importance: Undecided → High
Thierry Carrez (ttx) on 2010-03-04
Changed in eucalyptus (Ubuntu Lucid):
importance: High → Medium
status: New → Confirmed
Scott Moser (smoser) wrote :

I'm marking this as critical. This is serious error in functionality that makes the console almost completely unusable.

Changed in eucalyptus (Ubuntu Lucid):
importance: Medium → Critical
Thierry Carrez (ttx) wrote :

I say Medium, you say Critical, let's say it's High. It's not a regression, it does not kill any kitten, it does affect quite badly a secondary feature (the console output) but doesn't make it completely unusable...

@Dustin: you marked it as affecting euca2ools, does that mean you determined part of the bug lies in euca2ools ? Could you make sure Eucalyptus is aware of that bug, since we didn't mention it in yesterdays call ?

Changed in eucalyptus (Ubuntu Lucid):
importance: Critical → High
Thierry Carrez (ttx) wrote :

And now I see that Dustin already did the escalation... great !
About importance: it's pretty critical to Scott, so we need to fix this asap.

Changed in eucalyptus:
status: New → In Progress
assignee: nobody → chris grzegorczyk (chris-grze)
chris grzegorczyk (chris-grze) wrote :

@Thierry/Dustin: This bug is unrelated to euca2ools. I would go ahead and mark that is 'invalid'.

Looks like the semantics of the serial console changed while I was looking the other way.

------------------------------------------------------------
revno: 1206
committer: decker <decker@personal-army>
branch nick: 1.6.2
timestamp: Fri 2010-03-05 01:06:06 -0800
message:
  fix LP: #531536
------------------------------------------------------------

Changed in eucalyptus:
status: In Progress → Fix Committed
Thierry Carrez (ttx) wrote :

Marking euca2ools task Invalid, following Chris's advice, please reopen if I got it wrong.

Changed in euca2ools (Ubuntu Lucid):
status: New → Invalid

Definitely invalid against euca2ools.

I added that task for internet archival reasons. Someone searching
for this bug might look for or file it against euca2ools, and this
gets that text onto the page, even though ultimately it would be
closed as invalid.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2-0ubuntu10

---------------
eucalyptus (1.6.2-0ubuntu10) lucid; urgency=low

  * Cherry-pick merge from upstream 1.6.2 from revision 1199 to 1206,
    affecting:
    clc/modules/cluster-manager/src/main/java/edu/ucsb/eucalyptus/cloud/cluster/ConsoleOutputCallback.java,
    clc/modules/cluster-manager/src/main/java/edu/ucsb/eucalyptus/cloud/cluster/VmInstance.java,
    clc/modules/image-manager/src/main/java/edu/ucsb/eucalyptus/cloud/ws/ImageManager.java,
    clc/modules/image-manager/src/main/java/edu/ucsb/eucalyptus/cloud/ws/VolumeManager.java,
    clc/modules/storage-controller/src/main/java/edu/ucsb/eucalyptus/storage/LVM2Manager.java,
    tools/euca_conf.in
  * This merge is expected to fix:
    - LP: #526506 - fix volume attach to /dev/sda
    - LP: #525989 - improve handling of non-ramdisk images
    - LP: #531536 - handle get-console-output better
 -- Dustin Kirkland <email address hidden> Fri, 05 Mar 2010 09:30:29 -0600

Changed in eucalyptus (Ubuntu Lucid):
status: Confirmed → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers