[karmic]: attaching volume to /dev/sda results in non operational node

Bug #526506 reported by Torsten Spindler on 2010-02-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
chris grzegorczyk
eucalyptus (Ubuntu)
High
Dustin Kirkland 

Bug Description

I made a mistake when trying to attach a volume to an instance and gave it device /dev/sda. Instead of failing gracefully the node stopped to operate. Here's the log:

[Tue Feb 23 15:14:48 2010][001762][EUCAINFO ] started VM instance i-3B530725
[Tue Feb 23 15:18:13 2010][001762][EUCAINFO ] doAttachVolume() invoked (id=i-3B530725 vol=vol-333204B7 remote=/dev/etherd/e1.0 local=/dev/sda)
[Tue Feb 23 15:18:14 2010][001762][EUCAERROR ] libvirt: server closed connection (code=38)
[Tue Feb 23 15:18:14 2010][001762][EUCAERROR ] virDomainAttachDevice() failed (err=-1) XML=<disk type='block'><driver name='phy'/><source dev='/dev/etherd/e1.0'/><target dev='sda'/></disk>
[Tue Feb 23 15:18:14 2010][001762][EUCAERROR ] ERROR: doAttachVolume() failed error=1
[Tue Feb 23 15:18:16 2010][001762][EUCAERROR ] libvirt: cannot send data: Broken pipe (code=38)
[Tue Feb 23 15:18:16 2010][001762][EUCAWARN ] warning: hypervisor failed to find domain i-3B530725, will retry 4 more times
[Tue Feb 23 15:18:21 2010][001762][EUCAERROR ] libvirt: cannot send data: Broken pipe (code=38)
[Tue Feb 23 15:18:21 2010][001762][EUCAWARN ] warning: hypervisor failed to find domain i-3B530725, will retry 3 more times
[Tue Feb 23 15:18:26 2010][001762][EUCAERROR ] libvirt: cannot send data: Broken pipe (code=38)
[Tue Feb 23 15:18:26 2010][001762][EUCAWARN ] warning: hypervisor failed to find domain i-3B530725, will retry 2 more times

Torsten Spindler (tspindler) wrote :

Restarting libvirtd seemed to resolve the issue, albeit state is inconsistent thereafter.

Thierry Carrez (ttx) wrote :

Looks like the eucalyptus-libvirt link gets indeed broken by the user error, which makes it quite brittle. needs to be reproduced in lucid.

Changed in eucalyptus (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in eucalyptus:
status: New → In Progress
assignee: nobody → chris grzegorczyk (chris-grze)
chris grzegorczyk (chris-grze) wrote :

------------------------------------------------------------
revno: 1203
committer: decker <decker@personal-army>
branch nick: 1.6.2
timestamp: Fri 2010-03-05 01:04:41 -0800
message:
  fix LP: #526506
------------------------------------------------------------

Changed in eucalyptus:
status: In Progress → Fix Committed
Changed in eucalyptus (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2-0ubuntu10

---------------
eucalyptus (1.6.2-0ubuntu10) lucid; urgency=low

  * Cherry-pick merge from upstream 1.6.2 from revision 1199 to 1206,
    affecting:
    clc/modules/cluster-manager/src/main/java/edu/ucsb/eucalyptus/cloud/cluster/ConsoleOutputCallback.java,
    clc/modules/cluster-manager/src/main/java/edu/ucsb/eucalyptus/cloud/cluster/VmInstance.java,
    clc/modules/image-manager/src/main/java/edu/ucsb/eucalyptus/cloud/ws/ImageManager.java,
    clc/modules/image-manager/src/main/java/edu/ucsb/eucalyptus/cloud/ws/VolumeManager.java,
    clc/modules/storage-controller/src/main/java/edu/ucsb/eucalyptus/storage/LVM2Manager.java,
    tools/euca_conf.in
  * This merge is expected to fix:
    - LP: #526506 - fix volume attach to /dev/sda
    - LP: #525989 - improve handling of non-ramdisk images
    - LP: #531536 - handle get-console-output better
 -- Dustin Kirkland <email address hidden> Fri, 05 Mar 2010 09:30:29 -0600

Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers