block-device-mapping in metadata has 'ephemeral' not 'ephemeral0'

Bug #513842 reported by Scott Moser on 2010-01-28
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Medium
chris grzegorczyk
eucalyptus (Ubuntu)
Low
Dustin Kirkland 
Lucid
Low
Dustin Kirkland 

Bug Description

ubuntu@172:~$ python -c 'import boto.utils, pprint; pprint.pprint(boto.utils.get_instance_metadata())'
{'ami-id': 'emi-C8F2149C',
 'ami-launch-index': '0',
 'ami-manifest-path': 'http://192.168.0.151:8773/services/Walrus/i-20100125133728/lucid-server-uec-amd64.img.manifest.xml',
 'ancestor-ami-ids': '',
 'block-device-mapping': {'emi': 'sda1',
                          'ephemeral': 'sda2',
                          'root': '/dev/sda1',
                          'swap': 'sda3'},
<snip>

Above is from eucalyptus. Below is block-device-mapping from ec2:
 'block-device-mapping': {'ami': 'sda1',
                          'ephemeral0': 'sda2',
                          'root': '/dev/sda1',
                          'swap': 'sda3'},

The difference to note here is 'ephemeral', not 'ephemeral0'. This is easily reproduced with:

$ wget http://169.254.169.254/latest/meta-data/block-device-mapping -q -O -
ami
ephemeral0
root

Seen on eucalyptus 1.6.2~bzr1136-0ubuntu1

Dustin Kirkland  (kirkland) wrote :

Assigning to Dan, says he can look at this and fix upstream. Lowering priority. Dan will ping me once this is upstream and mergeable.

Changed in eucalyptus (Ubuntu):
status: New → Confirmed
assignee: nobody → Daniel Nurmi (nurmi)
milestone: none → lucid-alpha-3
importance: Medium → Low
Thierry Carrez (ttx) on 2010-02-02
Changed in eucalyptus (Ubuntu Lucid):
milestone: lucid-alpha-3 → none
Changed in eucalyptus:
status: New → In Progress
assignee: nobody → chris grzegorczyk (chris-grze)
importance: Undecided → Medium
chris grzegorczyk (chris-grze) wrote :

    ------------------------------------------------------------
    revno: 1185.1.1
    committer: decker <decker@hawaii>
    branch nick: metadata
    timestamp: Tue 2010-02-09 17:27:01 -0800
    message:
      ephemeral -> ephemeral0 LP:#513842
    ------------------------------------------------------------

Changed in eucalyptus:
status: In Progress → Fix Committed
Changed in eucalyptus (Ubuntu Lucid):
assignee: Daniel Nurmi (nurmi) → Dustin Kirkland (kirkland)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1189-0ubuntu1

---------------
eucalyptus (1.6.2~bzr1189-0ubuntu1) lucid; urgency=low

  [ Thierry Carrez ]
  * debian/rules: Start publication jobs on package install (LP: #504326)
  * debian/*publication.upstart: Do not advertise Walrus, SC, CC or NC if
    eucalyptus authorized_keys is missing, since autoregistration would then
    partially fail (LP: #513722)

  [ Dustin Kirkland ]
  * Merge from upstream bzr revision, should fix:
    - LP: #453416 - fix metadata subdirectory lists
    - LP: #513842 - fix metadata ephemeral verbage
 -- Dustin Kirkland <email address hidden> Thu, 11 Feb 2010 16:32:06 -0600

Changed in eucalyptus (Ubuntu Lucid):
status: In Progress → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers